ripple-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marc Luria <m...@luria.net>
Subject Re: ripple problem
Date Tue, 10 Sep 2013 16:10:37 GMT
I'm using a pc.  I'll try and see if it works.

What do you mean:

Right :-) But don't forget to disable Ripple if you also have it running as an
extension.




On Tue, Sep 10, 2013 at 6:45 PM, Dan Silivestru <dan.silivestru@gmail.com>wrote:

> Hey,
>
> Ok, here's the step by step. Sorry, sometimes Gord and I assume everyone is
> as familiar with Ripple as we are :)
>
> This is assuming you're on a Mac.
>
>
>    1. Open the terminal
>    2. type in: npm install -g ripple-emulator
>    3. navigate to your project directory
>    4. type in: ripple emulate
>    5. you should see something like this in the console:
>       - INFO: Server instance running on: http://localhost:4400
>       - INFO: CORS XHR proxy service on:
>       http://localhost:4400/ripple/xhr_proxy
>       - INFO: JSONP XHR proxy service on:
>       http://localhost:4400/ripple/jsonp_xhr_proxy
>    6. The port is 4400
>    7. The route is ripple
>    8. go to http://localhost:4400
>    9. Enable Ripple over the page
>    10. Expand the Settings pane
>    11. Select Local as the option for the Cross Origin Proxy
>    12. Make sure that the port and the route match whats in #6 and #7
>    13. Test away
>
> That should work for you.
>
> Cheers,
>
> Dan.
>
>
>
> On Tue, Sep 10, 2013 at 11:35 AM, Marc Luria <marc@luria.net> wrote:
>
> > I think I have it only running as a Chrome extension.
> >
> >
> > On Tue, Sep 10, 2013 at 6:11 PM, Dan Silivestru <
> dan.silivestru@gmail.com
> > >wrote:
> >
> > > Right :-) But don't forget to disable Ripple if you also have it
> running
> > as
> > > an extension.
> > >
> > >
> > >
> > >
> > > On Tue, Sep 10, 2013 at 11:01 AM, Gord Tanner <gtanner@gmail.com>
> wrote:
> > >
> > > > also ripple emulate will start a local proxy for you
> > > >
> > > >
> > > > On Tue, Sep 10, 2013 at 10:54 AM, Dan Silivestru
> > > > <dan.silivestru@gmail.com>wrote:
> > > >
> > > > > Hi Marc,
> > > > >
> > > > > You're in the right spot. Just pick Local and make sure your route
> > and
> > > > port
> > > > > are correct. You will see the value for those once your run the
> > > following
> > > > > command in the console (assuming you've installed npm
> > ripple-emulator)
> > > > >
> > > > > The command is:
> > > > >
> > > > > ripple proxy
> > > > >
> > > > > Cheers,
> > > > >
> > > > > Dan.
> > > > >
> > > > >
> > > > > On Tue, Sep 10, 2013 at 10:50 AM, Marc Luria <marc@luria.net>
> wrote:
> > > > >
> > > > > > I am now using 0.9.18 based on Brent's suggestion.
> > > > > >
> > > > > > How do I go to the setttings pane?  The settings pane I see
in
> > ripple
> > > > > has a
> > > > > > field Cross Domain Proxy which is set to Remote.  The other
two
> > > > settings
> > > > > > are Disabled and Local.
> > > > > >
> > > > > >
> > > > > >
> > > > > > m
> > > > > >
> > > > > >
> > > > > >
> > > > > > On Tue, Sep 10, 2013 at 4:32 PM, Dan Silivestru <
> > > > > dan.silivestru@gmail.com
> > > > > > >wrote:
> > > > > >
> > > > > > > You can also try installing the ripple from npm:
> > > > > > > https://npmjs.org/package/ripple-emulator
> > > > > > >
> > > > > > > Once it's installed globally just rung the ripple proxy
command
> > > over
> > > > > your
> > > > > > > project's directory and in Ripple, go to the settings pane
and
> > > change
> > > > > > your
> > > > > > > cross origin proxy settings to point to your local instance.
> > > > > > >
> > > > > > >
> > > > > > > On Tue, Sep 10, 2013 at 2:02 AM, Mayr Gregor <
> G.Mayr@cadenas.de>
> > > > > wrote:
> > > > > > >
> > > > > > > > Try starting Chrome with  "--disable-web-security"
Parameter.
> > > > > > > > This should allow you to do cross domain requests.
> > > > > > > > Otherwise you could put your origin into your server's
> > > > > > > > Access-Control-Allow-Origin header.
> > > > > > > >
> > > > > > > >
> > > > > > > > -----Urspr√ľngliche Nachricht-----
> > > > > > > > Von: Marc Luria [mailto:marc@luria.net]
> > > > > > > > Gesendet: Dienstag, 10. September 2013 01:46
> > > > > > > > An: dev@ripple.incubator.apache.org
> > > > > > > > Betreff: ripple problem
> > > > > > > >
> > > > > > > > using 0.9.18 in Chrome I'm getting the following error:
> > > > > > > >
> > > > > > > > XMLHttpRequest cannot load
> > > > > > > >
> > > > > > > > Origin http:/ <http://gamechat/>/mysite  is
not allowed by
> > > > > > > > Access-Control-Allow-Origin
> > > > > > > >
> > > > > > > > using 0.9.18 in Chrome I'm getting the following error:
> > > > > > > >
> > > > > > > > I don't think I've changed anything, though maybe
Chrome
> > updated,
> > > > it
> > > > > > was
> > > > > > > > working well before.  I tried going back a few versions
of
> > chrome
> > > > and
> > > > > > had
> > > > > > > > the same problem.
> > > > > > > >
> > > > > > > > Makes it hard to use AJAX.
> > > > > > > >
> > > > > > > > Any help or workaround would be appreciated.
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > --
> > > > > > > Dan Silivestru
> > > > > > > +1 (519) 589-3624
> > > > > > >
> > > > > >
> > > > >
> > > > >
> > > > >
> > > > > --
> > > > > Dan Silivestru
> > > > > +1 (519) 589-3624
> > > > >
> > > >
> > >
> > >
> > >
> > > --
> > > Dan Silivestru
> > > +1 (519) 589-3624
> > >
> >
>
>
>
> --
> Dan Silivestru
> +1 (519) 589-3624
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message