portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ate Douma <...@douma.nu>
Subject Re: j2.1.3 mvn plugin
Date Wed, 18 Nov 2009 10:35:04 GMT
Vlachogiannis Evangelos wrote:
> Hi,
> Thnx for the response again.. I tried to switch but same problem.  Let me try to describe
better my situation.
> 
> I have generated a custom portal (probably 2.2.0) and developed my portal. However as
I am need to use Graffito I realized that for SPI compatibility issues I need to go back to
2.1.3 version. What I did is just changing in my pom.xml org.apache.portals.jetspeed.version=2.1.3.
Then I get the following exception (see previous mail). I guess I am doing something terrible
wrong... Any idea pls??

Ugh, that very likely isn't going to work at all.
Jetspeed 2.2.x (please *do* check the version you've based this upon) is *very* different
from 2.1.3, especially build wise.
For Jetspeed 2.2.x we rewrote the maven (2.0.9+) build configuration completely and that is
definitely not backwards compatible with 2.1.3 
by just changing the jetspeed version property.
Furthermore, 2.2.x introduced some new artifacts (components etc.) and dropped some others
from 2.1.3, so your Jetspeed 2.2.x based pom.xml 
has *not* the same dependencies as needed for a 2.1.3 build.

I can only advise you to create a new custom portal project first based on 2.1.3 and then
migrate (back port) all your customizations to it.

FYI: I just did a clean build of jetspeed 2.1.3 source using maven 2.0.10 (after first temporarily
scrubbing my local maven repository) 
without any problems.

Regards,

Ate

> 
> Thnx a lot,
> Vangelis
> 
> From: Stanislav Brand [mailto:stanislav.brand@pageup.cz]
> Sent: Wednesday, November 18, 2009 11:35 AM
> To: Jetspeed Developers List
> Subject: Re: j2.1.3 mvn plugin
> 
> Hi Vangelis,
> which version of maven are you using? I was facing some problems using new version of
maven2. But switching to version 2.0.10 fixed all problems.
> 
> Standa
> 
> Vlachogiannis Evangelos wrote:
> 
> Thnx a lot got the response. I am using maven2 for jetspeed. Trying to run "mvn clean"
I am get the following...
> 
> 
> 
> [ERROR] BUILD ERROR
> 
> [INFO] ------------------------------------------------------------------------
> 
> [INFO] Error building POM (may not be this project's POM).
> 
> 
> 
> 
> 
> Project ID: org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin
> 
> 
> 
> Reason: POM 'org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin' not fou
> 
> nd in repository: Unable to download the artifact from any repository
> 
> 
> 
>   org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin:pom:2.1.3
> 
> 
> 
> from the specified remote repositories:
> 
>   bluesunrise (http://bluesunrise.com/maven2),
> 
>   central (http://repo1.maven.org/maven2)
> 
> 
> 
>  for project org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin
> 
> 
> 
> 
> 
> [INFO] ------------------------------------------------------------------------
> 
> [INFO] Trace
> 
> org.apache.maven.lifecycle.LifecycleExecutionException: Unable to build project
> 
> for plugin 'org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin': POM 'or
> 
> g.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin' not found in repositor
> 
> y: Unable to download the artifact from any repository
> 
> 
> 
>   org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin:pom:2.1.3
> 
> 
> 
> from the specified remote repositories:
> 
>   bluesunrise (http://bluesunrise.com/maven2),
> 
>   central (http://repo1.maven.org/maven2)
> 
> 
> 
>  for project org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin
> 
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.verifyPlugin(Defa
> 
> ultLifecycleExecutor.java:1557)
> 
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.bindPluginToLifec
> 
> ycle(DefaultLifecycleExecutor.java:1503)
> 
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.constructLifecycl
> 
> eMappings(DefaultLifecycleExecutor.java:1282)
> 
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(Defau
> 
> ltLifecycleExecutor.java:534)
> 
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHan
> 
> dleFailures(DefaultLifecycleExecutor.java:387)
> 
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegmen
> 
> ts(DefaultLifecycleExecutor.java:348)
> 
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLi
> 
> fecycleExecutor.java:180)
> 
>         at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:328)
> 
>         at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:138)
> 
>         at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
> 
>         at org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java:6
> 
> 0)
> 
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> 
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
> 
> java:39)
> 
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
> 
> sorImpl.java:25)
> 
>         at java.lang.reflect.Method.invoke(Method.java:597)
> 
>         at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
> 
>         at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
> 
>         at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
> 
> 
> 
>         at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
> 
> Caused by: org.apache.maven.plugin.InvalidPluginException: Unable to build proje
> 
> ct for plugin 'org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin': POM
> 
> 'org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin' not found in reposi
> 
> tory: Unable to download the artifact from any repository
> 
> 
> 
>   org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin:pom:2.1.3
> 
> 
> 
> from the specified remote repositories:
> 
>   bluesunrise (http://bluesunrise.com/maven2),
> 
>   central (http://repo1.maven.org/maven2)
> 
> 
> 
>  for project org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin
> 
>         at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersio
> 
> n(DefaultPluginManager.java:293)
> 
>         at org.apache.maven.plugin.DefaultPluginManager.verifyVersionedPlugin(De
> 
> faultPluginManager.java:205)
> 
>         at org.apache.maven.plugin.DefaultPluginManager.verifyPlugin(DefaultPlug
> 
> inManager.java:184)
> 
>         at org.apache.maven.plugin.DefaultPluginManager.loadPluginDescriptor(Def
> 
> aultPluginManager.java:1642)
> 
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.verifyPlugin(Defa
> 
> ultLifecycleExecutor.java:1540)
> 
>         ... 18 more
> 
> Caused by: org.apache.maven.project.ProjectBuildingException: POM 'org.apache.po
> 
> rtals.jetspeed-2:jetspeed-deploy-maven-plugin' not found in repository: Unable t
> 
> o download the artifact from any repository
> 
> 
> 
>   org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin:pom:2.1.3
> 
> 
> 
> from the specified remote repositories:
> 
>   bluesunrise (http://bluesunrise.com/maven2),
> 
>   central (http://repo1.maven.org/maven2)
> 
> 
> 
>  for project org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin
> 
>         at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepo
> 
> sitory(DefaultMavenProjectBuilder.java:605)
> 
>         at org.apache.maven.project.DefaultMavenProjectBuilder.buildFromReposito
> 
> ry(DefaultMavenProjectBuilder.java:251)
> 
>         at org.apache.maven.plugin.DefaultPluginManager.checkRequiredMavenVersio
> 
> n(DefaultPluginManager.java:277)
> 
>         ... 22 more
> 
> Caused by: org.apache.maven.artifact.resolver.ArtifactNotFoundException: Unable
> 
> to download the artifact from any repository
> 
> 
> 
>   org.apache.portals.jetspeed-2:jetspeed-deploy-maven-plugin:pom:2.1.3
> 
> 
> 
> from the specified remote repositories:
> 
>   bluesunrise (http://bluesunrise.com/maven2),
> 
>   central (http://repo1.maven.org/maven2)
> 
> 
> 
> 
> 
>         at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(De
> 
> faultArtifactResolver.java:228)
> 
>         at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(De
> 
> faultArtifactResolver.java:90)
> 
>         at org.apache.maven.project.DefaultMavenProjectBuilder.findModelFromRepo
> 
> sitory(DefaultMavenProjectBuilder.java:558)
> 
>         ... 24 more
> 
> Caused by: org.apache.maven.wagon.ResourceDoesNotExistException: Unable to downl
> 
> oad the artifact from any repository
> 
>         at org.apache.maven.artifact.manager.DefaultWagonManager.getArtifact(Def
> 
> aultWagonManager.java:404)
> 
>         at org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolve(De
> 
> faultArtifactResolver.java:216)
> 
>         ... 26 more
> 
> [INFO] ------------------------------------------------------------------------
> 
> [INFO] Total time: 2 seconds
> 
> [INFO] Finished at: Tue Nov 17 16:39:46 EET 2009
> 
> [INFO] Final Memory: 8M/56M
> 
> [INFO] ------------------------------------------------------------------------
> 
> 
> 
> -----Original Message-----
> 
> From: Randy Watler [mailto:watler@wispertel.net]
> 
> Sent: Tuesday, November 17, 2009 4:36 PM
> 
> To: Jetspeed Developers List
> 
> Subject: Re: j2.1.3 mvn plugin
> 
> 
> 
> Vangelis,
> 
> 
> 
> If you are using maven1, make sure you initialize the maven plugin since
> 
> you are building from source:
> 
> 
> 
>  > maven initMavenPlugin
> 
> 
> 
> The maven plugin is not required for the maven2 2.1.3 build.
> 
> 
> 
> http://portals.apache.org/jetspeed-2.1.3/devguide/m1-getting-started-source.html
> 
> http://portals.apache.org/jetspeed-2.1.3/devguide/maven-2-build.html
> 
> 
> 
> Randy
> 
> 
> 
> Vlachogiannis Evangelos wrote:
> 
> 
> 
> Hi List,
> 
> 
> 
> I am trying to build jetspeed 2.1.3 from source with mvn but maven cannot find jetspeed-mvn-maven-plugin:maven-plugin:2.1.3
in any of the repos.  Any help, pls?
> 
> 
> 
> Thnx,
> 
> Vangelis
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> 
> To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org<mailto:jetspeed-dev-unsubscribe@portals.apache.org>
> 
> For additional commands, e-mail: jetspeed-dev-help@portals.apache.org<mailto:jetspeed-dev-help@portals.apache.org>
> 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> 
> To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org<mailto:jetspeed-dev-unsubscribe@portals.apache.org>
> 
> For additional commands, e-mail: jetspeed-dev-help@portals.apache.org<mailto:jetspeed-dev-help@portals.apache.org>
> 
> 
> 
> 
> 
> --
> 
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message