portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gonzalo Aguilar Delgado <gagui...@aguilardelgado.com>
Subject Progress...
Date Fri, 20 Nov 2009 00:06:25 GMT
I've done several changes to the code. I'm near form the whole change.

But, I have a problem with the panel. I don't know what's the best way
to put
portlet information on web. 

It's supposed that I have to use the table already created but I don't
know how
te set information via YUI3:

+<table id="portlet-body-html" style="border-collapse: collapse; width:
100%; margin-top: 0px; margin-bottom: 0px; float: left;">
+    <tr>
+       <td rowspan="2" width="20%" class="portlet-section-body">
+           <img src='${portalContextPath}' />
+       </td>
+       <td id="name" width="80%" class="portlet-section-body">#</td>
+    </tr>       
+    <tr>
+       <td class="portlet-section-body">
+           <a href="#">Preview</a>  
+           <a href="#">Add</a>
+       </td>
+    </tr>
+</table>
+

I only managed to set the images. Normally a custom widget should be
created but I have
not enough knowledge about YUI. 

The rest works well... The only change needed is to do the filter to be
able to load on category click
but this will be trivial. 

If you help me to put information in each field I will finish this.


The rest of the changes:



        Prepatch-j2-admin-JS2-1057: 
        
                * Removed server retrieve of portlets (famous two lines)
                * Modified a bit the jsp code.
                
        
        Prepatch-jetspeed-2-JS2-1057:
        
                * portal.js - added ajax request and load using JSON
                * modified getportlets to handle json output.
                * GetPortletsAction - added support for JSON
                * Fixed a bug that caused xml and json fail when bad
                escaped texts found in description or name of the
                portlet.
                
                

It's not much but it took me a lot of time figure out how everything
glue, and setting dev environment caused some trouble :D

Your ideas will be welcome...

Tnx

Mime
View raw message