portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gonzalo Aguilar Delgado <gagui...@aguilardelgado.com>
Subject Re: Jetspeed SVN build [FIXED]
Date Fri, 13 Nov 2009 22:10:51 GMT
Hi, 

I just write to comment what happened. 

Downloading sources from eclipse will corrupt your configuration. I
don't know why but the only
way to make it work is to checkout without eclipse. And don't use it to
develop.

Can someone fix the problem?

Thank you all.



El vie, 13-11-2009 a las 20:55 +0000, Gonzalo Aguilar Delgado escribió:

> Hi Again, 
> 
> Sorry about being so repetitive. 
> 
> I found that web.xml file in here is right:
> /home/gad/.m2/repository/org/apache/portals/jetspeed-2/jetspeed/2.2.1-SNAPSHOT/jetspeed-2.2.1-SNAPSHOT.war
> 
> 
> The file under following directory is wrong:
> 
> /home/gad/.m2/repository/org/apache/portals/jetspeed-2/jetspeed-demo/2.2.1-SNAPSHOT/jetspeed-demo-2.2.1-SNAPSHOT.war
> 
> I attach the build log but I don't find anything wrong there... I hope
> it reach to the list...
> 
> I think that the problem is related to the overlay. But how can i
> check what's wrong?
> 
> 
> 
> 
> El vie, 13-11-2009 a las 05:05 -0800, Woonsan Ko escribió: 
> 
> > Hi Gonzalo,
> > 
> > I've tried build/deploy pluto-2.0.1-SNAPSHOT and Jetspeed-2.2.1-SNAPSHOT with Sun
JDK 1.6.0_13 under ubuntu 2.6.28, but I found no problem here.
> > Probably your build was not successful because it was mentioned that the deployed
web.xml was wrong, so I'd like to suggest you have a look into the build logs..
> > 
> > Just my two cents,
> > 
> > Woonsan
> > 
> > 
> > 
> > ----- Original Message ----
> > From: Gonzalo Aguilar Delgado <gaguilar@aguilardelgado.com>
> > To: Jetspeed Developers List <jetspeed-dev@portals.apache.org>
> > Sent: Fri, November 13, 2009 10:45:57 AM
> > Subject: Re: Jetspeed SVN build
> > 
> > Hi Woonsan, 
> > 
> > What I tried is:
> > 
> > 
> >         Run jetspeed 2.2.0 with openjdk-1.6     -> It works!
> >         Run jetspeed 2.2.0 with sun jdk-1.6     -> It works!
> >         Run jetspeed 2.2.1-trunk with sun jdk-1.6     ->  Fails with the
> >         error already shown
> >         Run jetspeed 2.2.1-trunk with openjdk-1.6     ->  Fails with the
> >         error already shown
> >         
> >         Run Run jetspeed 2.2.1-trunk with openjdk-1.5-gjc     ->  Fails
> >         running catalina. But maybe because my ubuntu karmic...
> >         
> > 
> > I cannot go back to 1.5 because ubuntu karmic does not support it well I
> > suppose.
> > 
> >         
> > 
> > What I don't understand is why 2.2.0 works with 1.6 and 2.2.1 does not.
> > What changed between releases?
> > 
> > Thank you.
> > 
> >         
> > 
> > 
> > 
> > 
> > El vie, 13-11-2009 a las 01:13 -0800, Woonsan Ko escribió:
> > 
> > > Hi Gonzalo,
> > > 
> > > Do you mean that the problem happens only when you try to build and deploy
from the source with openjdk-1.6 or openjdk-1.5?
> > > If it is the case, could you try it with other JDK 1.5 as well? I haven't met
any problem with Sun JDK 1.5.
> > > 
> > > Regards,
> > > 
> > > Woonsan
> > > 
> > > 
> > > 
> > > ----- Original Message ----
> > > From: Gonzalo Aguilar Delgado <gaguilar@aguilardelgado.com>
> > > To: Jetspeed Developers List <jetspeed-dev@portals.apache.org>
> > > Sent: Thu, November 12, 2009 6:08:45 PM
> > > Subject: Re: Jetspeed SVN build
> > > 
> > > I tried to run it with 1.5 JVM but it does not work.
> > > 
> > > Should I open a bug ?
> > > 
> > > Tnx
> > > 
> > > 
> > > El jue, 12-11-2009 a las 17:53 +0100, Gonzalo Aguilar Delgado escribió:
> > > 
> > > > Hi Woonsan, 
> > > > 
> > > > But I already used Jetspeed 2.2.0 using jvm 1.6 and it works well.
> > > > Should this be a regression problem?
> > > > 
> > > > And also I noticed that external JAXB jars are in the lib library path.
> > > > So I don't know why it gets the internal ones...
> > > > 
> > > > I will try with 1.5 anyway, tnx
> > > > 
> > > > 
> > > > 
> > > > El jue, 12-11-2009 a las 07:58 -0800, Woonsan Ko escribió:
> > > > 
> > > > > Hi Gonzalo,
> > > > > 
> > > > > I think it would work with JVM 1.5.
> > > > > IMHO, your openjdk 1.6 VM already has JAXB classes and it does not
allow it own system classes to be replaced by other JAXB jar, which must be added by pluto
distribution.
> > > > > 
> > > > > Regards,
> > > > > 
> > > > > Woonsan
> > > > > 
> > > > > --- On Thu, 11/12/09, Gonzalo Aguilar Delgado <gaguilar@aguilardelgado.com>
wrote:
> > > > > 
> > > > > > From: Gonzalo Aguilar Delgado <gaguilar@aguilardelgado.com>
> > > > > > Subject: Re: Jetspeed SVN build
> > > > > > To: "Jetspeed Developers List" <jetspeed-dev@portals.apache.org>
> > > > > > Date: Thursday, November 12, 2009, 1:56 PM
> > > > > > Hi again, 
> > > > > > 
> > > > > > I replaced the web.xml with the one that comes from
> > > > > > binaries and it
> > > > > > worked but I found the following problem:
> > > > > > 
> > > > > > Caused by:
> > > > > > org.springframework.beans.factory.BeanCreationException:
> > > > > > Error creating bean with name
> > > > > > 'org.apache.pluto.services.PlutoServices'
> > > > > > defined in ServletContext resource
> > > > > > [/WEB-INF/assembly/pluto-services.xml]: Cannot resolve
> > > > > > reference to bean
> > > > > > 'org.apache.pluto.services.EventCoordinationService' while
> > > > > > setting
> > > > > > constructor argument; nested exception is
> > > > > > org.springframework.beans.factory.BeanCreationException:
> > > > > > Error creating
> > > > > > bean with name
> > > > > > 'org.apache.pluto.services.EventCoordinationService'
> > > > > > defined in ServletContext resource
> > > > > > [/WEB-INF/assembly/pluto-services.xml]: Instantiation of
> > > > > > bean failed;
> > > > > > nested exception is
> > > > > > org.springframework.beans.BeanInstantiationException: Could
> > > > > > not
> > > > > > instantiate bean class
> > > > > > [org.apache.jetspeed.events.EventCoordinationServiceImpl]:
> > > > > > Constructor
> > > > > > threw exception; nested exception is java.lang.Error:
> > > > > > Unresolved
> > > > > > compilation problems: 
> > > > > >     Access restriction: The type JAXBContext
> > > > > > is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type
> > > > > > JAXBElement<T> is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type
> > > > > > JAXBException is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type Marshaller
> > > > > > is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type
> > > > > > Unmarshaller is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type
> > > > > > XMLInputFactory is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type
> > > > > > XMLStreamReader is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type JAXBContext
> > > > > > is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type JAXBContext
> > > > > > is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The method
> > > > > > newInstance(Class[]) from the type
> > > > > > JAXBContext is not accessible due to restriction on
> > > > > > required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type Marshaller
> > > > > > is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The method
> > > > > > createMarshaller() from the type
> > > > > > JAXBContext is not accessible due to restriction on
> > > > > > required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type
> > > > > > JAXBElement<Serializable> is not
> > > > > > accessible due to restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The constructor
> > > > > > JAXBElement(QName, Class, Object)
> > > > > > is not accessible due to restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type
> > > > > > JAXBElement<T> is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The method
> > > > > > marshal(Object, Writer) from the type
> > > > > > Marshaller is not accessible due to restriction on
> > > > > > required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type
> > > > > > JAXBException is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type
> > > > > > XMLStreamReader is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type
> > > > > > XMLInputFactory is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The method
> > > > > > newInstance() from the type
> > > > > > XMLInputFactory is not accessible due to restriction on
> > > > > > required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The method
> > > > > > createXMLStreamReader(Reader) from the
> > > > > > type XMLInputFactory is not accessible due to restriction
> > > > > > on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type JAXBContext
> > > > > > is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type JAXBContext
> > > > > > is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The method
> > > > > > newInstance(Class[]) from the type
> > > > > > JAXBContext is not accessible due to restriction on
> > > > > > required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type
> > > > > > Unmarshaller is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The method
> > > > > > createUnmarshaller() from the type
> > > > > > JAXBContext is not accessible due to restriction on
> > > > > > required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The type
> > > > > > JAXBElement<T> is not accessible due to
> > > > > > restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The method
> > > > > > unmarshal(XMLStreamReader,
> > > > > > Class<capture#20-of ? extends Serializable>) from the
> > > > > > type Unmarshaller
> > > > > > is not accessible due to restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > >     Access restriction: The method
> > > > > > getValue() from the type JAXBElement is
> > > > > > not accessible due to restriction on required
> > > > > > library /usr/lib/jvm/java-6-openjdk/jre/lib/rt.jar
> > > > > > 
> > > > > > 
> > > > > > 
> > > > > > Any help on this also?
> > > > > > 
> > > > > > El jue, 12-11-2009 a las 13:52 +0100, Gonzalo Aguilar
> > > > > > Delgado escribió:
> > > > > > 
> > > > > > > Hi, 
> > > > > > > 
> > > > > > > I followed all directions given in
> > > > > > > http://portals.apache.org/jetspeed-2/buildguide/maven-2-build.html
> > > > > > > 
> > > > > > > but I found that when deployed the web.xml only
> > > > > > contains this:
> > > > > > > 
> > > > > > > <?xml version="1.0" encoding="UTF-8"?>
> > > > > > > <web-app xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> > > > > > > xmlns="http://java.sun.com/xml/ns/javaee"
> > > > > > > xmlns:web="http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"
> > > > > > > xsi:schemaLocation="http://java.sun.com/xml/ns/javaee
> > > > > > > http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd"
> > > > > > id="WebApp_ID"
> > > > > > > version="2.5">
> > > > > > >   <display-name>jetspeed-demo</display-name>
> > > > > > >   <welcome-file-list>
> > > > > > > 
> > > > > >    <welcome-file>index.html</welcome-file>
> > > > > > > 
> > > > > >    <welcome-file>index.htm</welcome-file>
> > > > > > > 
> > > > > >    <welcome-file>index.jsp</welcome-file>
> > > > > > > 
> > > > > >    <welcome-file>default.html</welcome-file>
> > > > > > > 
> > > > > >    <welcome-file>default.htm</welcome-file>
> > > > > > > 
> > > > > >    <welcome-file>default.jsp</welcome-file>
> > > > > > >   </welcome-file-list>
> > > > > > > </web-app>
> > > > > > > 
> > > > > > > 
> > > > > > > As this is not the correct web.xml what's the step I
> > > > > > missed.
> > > > > > > 
> > > > > > > Thank you!
> > > > > > > 
> > > > > > > 
> > > > > > 
> > > > > 
> > > > > 
> > > > >      
> > > > > 
> > > > > ---------------------------------------------------------------------
> > > > > To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
> > > > > For additional commands, e-mail: jetspeed-dev-help@portals.apache.org
> > > > > 
> > > 
> > > 
> > > 
> > >      
> > > 
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
> > > For additional commands, e-mail: jetspeed-dev-help@portals.apache.org
> > > 
> > 
> > 
> > 
> >       
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
> > For additional commands, e-mail: jetspeed-dev-help@portals.apache.org
> > 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
> For additional commands, e-mail: jetspeed-dev-help@portals.apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message