portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Sean Taylor <d.tay...@onehippo.com>
Subject Re: Possible portal site manager bug
Date Fri, 02 Oct 2009 00:15:51 GMT

On Oct 1, 2009, at 3:34 PM, Brad Gardner wrote:

> Jetspeed 2.2.0 is the version I am using.  Here is what I did:
>
> Navigate to "jetspeed administrative portlets"
> Navigate to "Portal Site Manager"
> Click on "_role" folder
> Click on "add subfolder" and entered name="test" title and short  
> title both
> = "test page"
> Click on the newly created "test" folder
> Click "add page" and entered name="mypage" title and short title  
> both = "my
> page"
>
> If i specify the page name as "test.psml" the resulting page becomes
> "test.psml.psml" so I omitted this in my tests.  Creating the file  
> this way
> yields the same results as well.  Is there somewhere that the  
> default layout
> is specified?  Maybe I'm missing a default setting.

Shouldn't matter. We use the jetspeed.properties (or  
override.properties) to retrieve the layout.page.default. But if it is  
not configured, then it uses VelocityOneColumn as the default:

                      
page 
.getRootFragment 
().setName 
(getServiceLocator 
().getPortalConfiguration().getString("layout.page.default", "jetspeed- 
layouts::VelocityOneColumn"));

Check your override and jetspeed properties and ensure that  
layout.page.default is set

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message