portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Sean Taylor <d.tay...@onehippo.com>
Subject Re: jetspeed tutorial error during build
Date Thu, 03 Sep 2009 22:32:01 GMT
Looks like everything BUILT SUCCESSFUL

Have you tried starting up Tomcat ....

There are several log files of interest (if it fails to start) under  
Tomcat's logs directory:

jetspeed*.log, look for any files > 0 bytes
localhost.2009-09-03.log (assuming you are running today)
catalina.2009-09-03.log

On Sep 3, 2009, at 2:16 PM, Dahl, Sandra wrote:

> Here is the result using derby:
> [INFO] Scanning for projects...
> [INFO] Reactor build order:
> [INFO]   jetexpress portal project
> [INFO]   jetexpress portal
> [INFO]   jetexpress portlet application
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Building jetexpress portal project
> [INFO]    task-segment: [org.apache.portals.jetspeed-2:jetspeed-mvn- 
> maven-plugin:2.2.0:mvn] (aggregator-style)
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] [jetspeed:mvn]
> [INFO] Resolved target(s) order: [install-portal, install-pa,  
> install, db-portal, db, deploy-portal, deploy-pa, all]
> [INFO] Executing target: install-portal
> [INFO] Invoking target install-portal: C:\eclipseWorkspace\jetexpress 
> \jetexpress-portal\pom.xml clean install
> + Error stacktraces are turned on.
> [INFO] Scanning for projects...
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Building jetexpress portal
> [INFO]    task-segment: [clean, install]
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] [clean:clean {execution: default-clean}]
> [INFO] Deleting directory C:\eclipseWorkspace\jetexpress\jetexpress- 
> portal\target
> [INFO] [resources:resources {execution: default-resources}]
> [WARNING] Using platform encoding (Cp1252 actually) to copy filtered  
> resources, i.e. build is platform dependent!
> [INFO] skip non existing resourceDirectory C:\eclipseWorkspace 
> \jetexpress\jetexpress-portal\src\main\resources
> [INFO] [jetspeed-deploy:deploy {execution: deploy-jetspeed-layouts}]
> [INFO] Deploying to targetBaseDir C:\eclipseWorkspace\jetexpress 
> \jetexpress-portal\target\jetexpress-portal-1.0-SHAPSHOT
> [INFO]   deploying to local: jetspeed-layouts.war
> [INFO] [compiler:compile {execution: default-compile}]
> [INFO] No sources to compile
> [INFO] [resources:testResources {execution: default-testResources}]
> [WARNING] Using platform encoding (Cp1252 actually) to copy filtered  
> resources, i.e. build is platform dependent!
> [INFO] skip non existing resourceDirectory C:\eclipseWorkspace 
> \jetexpress\jetexpress-portal\src\test\resources
> [INFO] [compiler:testCompile {execution: default-testCompile}]
> [INFO] No sources to compile
> [INFO] [surefire:test {execution: default-test}]
> [INFO] No tests to run.
> [INFO] [war:war {execution: default-war}]
> [INFO] Packaging webapp
> [INFO] Assembling webapp[jetexpress-portal] in [C:\eclipseWorkspace 
> \jetexpress\jetexpress-portal\target\jetexpress-portal-1.0-SHAPSHOT]
> [INFO] Processing war project
> [INFO] Copying webapp resources[C:\eclipseWorkspace\jetexpress 
> \jetexpress-portal\src\main\webapp]
> [INFO] Processing overlay[ id org.apache.portals.jetspeed-2:jetspeed]
> [INFO] Webapp assembled in[31375 msecs]
> [INFO] Building war: C:\eclipseWorkspace\jetexpress\jetexpress-portal 
> \target\jetexpress-portal.war
> [INFO] [install:install {execution: default-install}]
> [INFO] Installing C:\eclipseWorkspace\jetexpress\jetexpress-portal 
> \target\jetexpress-portal.war to C:\Maven\.m2\repository\com\tdiinc 
> \tutorials\jetexpress-portal\1.0-SHAPSHOT\jetexpress-portal-1.0- 
> SHAPSHOT.war
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESSFUL
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Total time: 56 seconds
> [INFO] Finished at: Thu Sep 03 14:11:07 MST 2009
> [INFO] Final Memory: 24M/43M
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] ...SUCCESS.
> [INFO] Executing target: install-pa
> [INFO] Invoking target install-pa: C:\eclipseWorkspace\jetexpress 
> \jetexpress-pa\pom.xml clean install
> + Error stacktraces are turned on.
> [INFO] Scanning for projects...
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Building jetexpress portlet application
> [INFO]    task-segment: [clean, install]
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] [clean:clean {execution: default-clean}]
> [INFO] Deleting directory C:\eclipseWorkspace\jetexpress\jetexpress- 
> pa\target
> [INFO] [resources:resources {execution: default-resources}]
> [WARNING] Using platform encoding (Cp1252 actually) to copy filtered  
> resources, i.e. build is platform dependent!
> [INFO] skip non existing resourceDirectory C:\eclipseWorkspace 
> \jetexpress\jetexpress-pa\src\main\resources
> [INFO] [compiler:compile {execution: default-compile}]
> [INFO] Compiling 1 source file to C:\eclipseWorkspace\jetexpress 
> \jetexpress-pa\target\classes
> [INFO] [resources:testResources {execution: default-testResources}]
> [WARNING] Using platform encoding (Cp1252 actually) to copy filtered  
> resources, i.e. build is platform dependent!
> [INFO] skip non existing resourceDirectory C:\eclipseWorkspace 
> \jetexpress\jetexpress-pa\src\test\resources
> [INFO] [compiler:testCompile {execution: default-testCompile}]
> [INFO] No sources to compile
> [INFO] [surefire:test {execution: default-test}]
> [INFO] No tests to run.
> [INFO] [war:war {execution: default-war}]
> [INFO] Packaging webapp
> [INFO] Assembling webapp[jetexpress-pa] in [C:\eclipseWorkspace 
> \jetexpress\jetexpress-pa\target\jetexpress-pa]
> [INFO] Processing war project
> [INFO] Copying webapp resources[C:\eclipseWorkspace\jetexpress 
> \jetexpress-pa\src\main\webapp]
> [INFO] Webapp assembled in[78 msecs]
> [INFO] Building war: C:\eclipseWorkspace\jetexpress\jetexpress-pa 
> \target\jetexpress-pa.war
> [INFO] [install:install {execution: default-install}]
> [INFO] Installing C:\eclipseWorkspace\jetexpress\jetexpress-pa\target 
> \jetexpress-pa.war to C:\Maven\.m2\repository\com\tdiinc\tutorials 
> \jetexpress-pa\1.0-SHAPSHOT\jetexpress-pa-1.0-SHAPSHOT.war
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESSFUL
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Total time: 2 seconds
> [INFO] Finished at: Thu Sep 03 14:11:11 MST 2009
> [INFO] Final Memory: 14M/26M
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] ...SUCCESS.
> [INFO] Executing target: install dependent on [install- 
> portal,install-pa] ONLY: all done
> [INFO] Executing target: db-portal dependent on [install-portal]
> [INFO] Invoking target db-portal: C:\eclipseWorkspace\jetexpress 
> \jetexpress-portal\jetspeed-mvn-portal-pom.xml db
> + Error stacktraces are turned on.
> [INFO] Scanning for projects...
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Building Jetspeed-2 Maven Invoker Configuration for My Portal
> [INFO]    task-segment: [process-resources]
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] [jetspeed-db:init {execution: unpack}]
> [INFO] [jetspeed-db:init {execution: execute-sql}]
> [INFO] Running sql scripts against: jdbc:derby:/derby/ 
> jetexpress;create=true for user:
> [INFO] Executing SQL script file: C:\eclipseWorkspace\jetexpress 
> \jetexpress-portal\target\ddl\derby\drop-schema.sql
> [INFO] Executing SQL script file: C:\eclipseWorkspace\jetexpress 
> \jetexpress-portal\target\ddl\derby\create-schema.sql
> [INFO] [jetspeed-db:init {execution: seed}]
> log4j:WARN No appenders could be found for logger  
> (org.apache.jetspeed.components.JetspeedBeanDefinitionFilter).
> log4j:WARN Please initialize the log4j system properly.
> ##### platform = Hsqldb
> [INFO] creating clients, mediatypes and mimetypes
> [INFO] creating principals and permissions
> [INFO] creating permissions
> [INFO] creating profiling rules and user profiling rules
> [INFO] creating entities
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESSFUL
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Total time: 36 seconds
> [INFO] Finished at: Thu Sep 03 14:11:47 MST 2009
> [INFO] Final Memory: 21M/38M
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] ...SUCCESS.
> [INFO] Executing target: db dependent on [db-portal] ONLY: all done
> [INFO] Executing target: deploy-portal dependent on [install]
> [INFO] Invoking target deploy-portal: C:\eclipseWorkspace\jetexpress 
> \jetexpress-portal\jetspeed-mvn-portal-pom.xml deploy
> + Error stacktraces are turned on.
> [INFO] Scanning for projects...
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Building Jetspeed-2 Maven Invoker Configuration for My Portal
> [INFO]    task-segment: [process-resources]
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] [jetspeed-unpack:unpack {execution: unpack-appserver}]
> [INFO] [resources:resources {execution: resources}]
> [WARNING] File encoding has not been set, using platform encoding  
> Cp1252, i.e. build is platform dependent!
> [WARNING] Using platform encoding (Cp1252 actually) to copy filtered  
> resources, i.e. build is platform dependent!
> [INFO] skip non existing resourceDirectory C:\eclipseWorkspace 
> \jetexpress\jetexpress-portal\src\conf
> [INFO] Copying 1 resource to ../resources
> [WARNING] While downloading xml-apis:xml-apis:2.0.2
>  This artifact has been relocated to xml-apis:xml-apis:1.0.b2.
>
>
> [INFO] [jetspeed-deploy:deploy {execution: deploy}]
> [INFO] Deploying to targetBaseDir c:\apache-tomcat-6.0.14
> [INFO]   deploying to lib: portlet-api_2.0_spec-1.0.jar
> [INFO]   deploying to lib: ccpp-1.0.jar
> [INFO]   deploying to lib: jetspeed-api-2.2.0.jar
> [INFO]   deploying to lib: jetspeed-commons-2.2.0.jar
> [INFO]   deploying to lib: pluto-container-api-2.0.0.jar
> [INFO]   deploying to lib: pluto-taglib-2.0.0.jar
> [INFO]   deploying to lib: portals-bridges-common-1.0.4.jar
> [INFO]   deploying to system: derby-10.3.2.1.jar
> [INFO]   deploying to war: jetexpress (expanded)
> [INFO]   deploying to context: jetexpress.xml
> [INFO]   deploying to war: j2-admin.war
> [INFO]   deploying to server-lib: apa-logging-1.0.jar
> [INFO]   editing in server-conf: server.xml using  
> ServerXMLConfigurer.verifyAndConfigureServerXML()
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESSFUL
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Total time: 18 seconds
> [INFO] Finished at: Thu Sep 03 14:12:06 MST 2009
> [INFO] Final Memory: 10M/19M
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] ...SUCCESS.
> [INFO] Executing target: deploy-pa dependent on [install-pa]
> [INFO] Invoking target deploy-pa: C:\eclipseWorkspace\jetexpress 
> \jetexpress-pa\jetspeed-mvn-pa-pom.xml deploy
> + Error stacktraces are turned on.
> [INFO] Scanning for projects...
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Building Jetspeed-2 Maven Invoker Configuration for My  
> Portlet Application
> [INFO]    task-segment: [process-resources]
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] [jetspeed-deploy:deploy {execution: deploy}]
> [INFO] Deploying to targetBaseDir c:\apache-tomcat-6.0.14
> [INFO]   deploying to war: jetexpress-pa (infused, expanded)
> Found WEB-INF/portlet.xml
> Found web.xml
> Attempting to add portlet.tld to war...
> Adding portlet.tld to war...
> Attempting to add portlet_2_0.tld to war...
> Adding portlet_2_0.tld to war...
> Creating war C:\DOCUME~1\SDahl\LOCALS~1\Temp\jetexpress-pa-1.0- 
> SHAPSHOT.war.infused-905850823820826403 ...
> War C:\DOCUME~1\SDahl\LOCALS~1\Temp\jetexpress-pa-1.0- 
> SHAPSHOT.war.infused-905850823820826403 created
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESSFUL
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Total time: < 1 second
> [INFO] Finished at: Thu Sep 03 14:12:07 MST 2009
> [INFO] Final Memory: 4M/8M
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] ...SUCCESS.
> [INFO] Executing target: all dependent on [install,db,deploy- 
> portal,deploy-pa] ONLY: all done
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESSFUL
> [INFO]  
> ------------------------------------------------------------------------
> [INFO] Total time: 1 minute 58 seconds
> [INFO] Finished at: Thu Sep 03 14:12:07 MST 2009
> [INFO] Final Memory: 5M/9M
> [INFO]  
> ------------------------------------------------------------------------
>
> Sandi

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message