portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dahl, Sandra" <SD...@TDIinc.com>
Subject RE: jetspeed tutorial error during build
Date Thu, 03 Sep 2009 21:16:14 GMT
Here is the result using derby:
[INFO] Scanning for projects...
[INFO] Reactor build order:
[INFO]   jetexpress portal project
[INFO]   jetexpress portal
[INFO]   jetexpress portlet application
[INFO] ------------------------------------------------------------------------
[INFO] Building jetexpress portal project
[INFO]    task-segment: [org.apache.portals.jetspeed-2:jetspeed-mvn-maven-plugin:2.2.0:mvn]
(aggregator-style)
[INFO] ------------------------------------------------------------------------
[INFO] [jetspeed:mvn]
[INFO] Resolved target(s) order: [install-portal, install-pa, install, db-portal, db, deploy-portal,
deploy-pa, all]
[INFO] Executing target: install-portal
[INFO] Invoking target install-portal: C:\eclipseWorkspace\jetexpress\jetexpress-portal\pom.xml
clean install
+ Error stacktraces are turned on.
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building jetexpress portal
[INFO]    task-segment: [clean, install]
[INFO] ------------------------------------------------------------------------
[INFO] [clean:clean {execution: default-clean}]
[INFO] Deleting directory C:\eclipseWorkspace\jetexpress\jetexpress-portal\target
[INFO] [resources:resources {execution: default-resources}]
[WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build
is platform dependent!
[INFO] skip non existing resourceDirectory C:\eclipseWorkspace\jetexpress\jetexpress-portal\src\main\resources
[INFO] [jetspeed-deploy:deploy {execution: deploy-jetspeed-layouts}]
[INFO] Deploying to targetBaseDir C:\eclipseWorkspace\jetexpress\jetexpress-portal\target\jetexpress-portal-1.0-SHAPSHOT
[INFO]   deploying to local: jetspeed-layouts.war
[INFO] [compiler:compile {execution: default-compile}]
[INFO] No sources to compile
[INFO] [resources:testResources {execution: default-testResources}]
[WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build
is platform dependent!
[INFO] skip non existing resourceDirectory C:\eclipseWorkspace\jetexpress\jetexpress-portal\src\test\resources
[INFO] [compiler:testCompile {execution: default-testCompile}]
[INFO] No sources to compile
[INFO] [surefire:test {execution: default-test}]
[INFO] No tests to run.
[INFO] [war:war {execution: default-war}]
[INFO] Packaging webapp
[INFO] Assembling webapp[jetexpress-portal] in [C:\eclipseWorkspace\jetexpress\jetexpress-portal\target\jetexpress-portal-1.0-SHAPSHOT]
[INFO] Processing war project
[INFO] Copying webapp resources[C:\eclipseWorkspace\jetexpress\jetexpress-portal\src\main\webapp]
[INFO] Processing overlay[ id org.apache.portals.jetspeed-2:jetspeed]
[INFO] Webapp assembled in[31375 msecs]
[INFO] Building war: C:\eclipseWorkspace\jetexpress\jetexpress-portal\target\jetexpress-portal.war
[INFO] [install:install {execution: default-install}]
[INFO] Installing C:\eclipseWorkspace\jetexpress\jetexpress-portal\target\jetexpress-portal.war
to C:\Maven\.m2\repository\com\tdiinc\tutorials\jetexpress-portal\1.0-SHAPSHOT\jetexpress-portal-1.0-SHAPSHOT.war
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 56 seconds
[INFO] Finished at: Thu Sep 03 14:11:07 MST 2009
[INFO] Final Memory: 24M/43M
[INFO] ------------------------------------------------------------------------
[INFO] ...SUCCESS.
[INFO] Executing target: install-pa
[INFO] Invoking target install-pa: C:\eclipseWorkspace\jetexpress\jetexpress-pa\pom.xml clean
install
+ Error stacktraces are turned on.
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building jetexpress portlet application
[INFO]    task-segment: [clean, install]
[INFO] ------------------------------------------------------------------------
[INFO] [clean:clean {execution: default-clean}]
[INFO] Deleting directory C:\eclipseWorkspace\jetexpress\jetexpress-pa\target
[INFO] [resources:resources {execution: default-resources}]
[WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build
is platform dependent!
[INFO] skip non existing resourceDirectory C:\eclipseWorkspace\jetexpress\jetexpress-pa\src\main\resources
[INFO] [compiler:compile {execution: default-compile}]
[INFO] Compiling 1 source file to C:\eclipseWorkspace\jetexpress\jetexpress-pa\target\classes
[INFO] [resources:testResources {execution: default-testResources}]
[WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build
is platform dependent!
[INFO] skip non existing resourceDirectory C:\eclipseWorkspace\jetexpress\jetexpress-pa\src\test\resources
[INFO] [compiler:testCompile {execution: default-testCompile}]
[INFO] No sources to compile
[INFO] [surefire:test {execution: default-test}]
[INFO] No tests to run.
[INFO] [war:war {execution: default-war}]
[INFO] Packaging webapp
[INFO] Assembling webapp[jetexpress-pa] in [C:\eclipseWorkspace\jetexpress\jetexpress-pa\target\jetexpress-pa]
[INFO] Processing war project
[INFO] Copying webapp resources[C:\eclipseWorkspace\jetexpress\jetexpress-pa\src\main\webapp]
[INFO] Webapp assembled in[78 msecs]
[INFO] Building war: C:\eclipseWorkspace\jetexpress\jetexpress-pa\target\jetexpress-pa.war
[INFO] [install:install {execution: default-install}]
[INFO] Installing C:\eclipseWorkspace\jetexpress\jetexpress-pa\target\jetexpress-pa.war to
C:\Maven\.m2\repository\com\tdiinc\tutorials\jetexpress-pa\1.0-SHAPSHOT\jetexpress-pa-1.0-SHAPSHOT.war
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2 seconds
[INFO] Finished at: Thu Sep 03 14:11:11 MST 2009
[INFO] Final Memory: 14M/26M
[INFO] ------------------------------------------------------------------------
[INFO] ...SUCCESS.
[INFO] Executing target: install dependent on [install-portal,install-pa] ONLY: all done
[INFO] Executing target: db-portal dependent on [install-portal]
[INFO] Invoking target db-portal: C:\eclipseWorkspace\jetexpress\jetexpress-portal\jetspeed-mvn-portal-pom.xml
db
+ Error stacktraces are turned on.
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building Jetspeed-2 Maven Invoker Configuration for My Portal
[INFO]    task-segment: [process-resources]
[INFO] ------------------------------------------------------------------------
[INFO] [jetspeed-db:init {execution: unpack}]
[INFO] [jetspeed-db:init {execution: execute-sql}]
[INFO] Running sql scripts against: jdbc:derby:/derby/jetexpress;create=true for user:
[INFO] Executing SQL script file: C:\eclipseWorkspace\jetexpress\jetexpress-portal\target\ddl\derby\drop-schema.sql
[INFO] Executing SQL script file: C:\eclipseWorkspace\jetexpress\jetexpress-portal\target\ddl\derby\create-schema.sql
[INFO] [jetspeed-db:init {execution: seed}]
log4j:WARN No appenders could be found for logger (org.apache.jetspeed.components.JetspeedBeanDefinitionFilter).
log4j:WARN Please initialize the log4j system properly.
##### platform = Hsqldb
[INFO] creating clients, mediatypes and mimetypes
[INFO] creating principals and permissions
[INFO] creating permissions
[INFO] creating profiling rules and user profiling rules
[INFO] creating entities
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 36 seconds
[INFO] Finished at: Thu Sep 03 14:11:47 MST 2009
[INFO] Final Memory: 21M/38M
[INFO] ------------------------------------------------------------------------
[INFO] ...SUCCESS.
[INFO] Executing target: db dependent on [db-portal] ONLY: all done
[INFO] Executing target: deploy-portal dependent on [install]
[INFO] Invoking target deploy-portal: C:\eclipseWorkspace\jetexpress\jetexpress-portal\jetspeed-mvn-portal-pom.xml
deploy
+ Error stacktraces are turned on.
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building Jetspeed-2 Maven Invoker Configuration for My Portal
[INFO]    task-segment: [process-resources]
[INFO] ------------------------------------------------------------------------
[INFO] [jetspeed-unpack:unpack {execution: unpack-appserver}]
[INFO] [resources:resources {execution: resources}]
[WARNING] File encoding has not been set, using platform encoding Cp1252, i.e. build is platform
dependent!
[WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build
is platform dependent!
[INFO] skip non existing resourceDirectory C:\eclipseWorkspace\jetexpress\jetexpress-portal\src\conf
[INFO] Copying 1 resource to ../resources
[WARNING] While downloading xml-apis:xml-apis:2.0.2
  This artifact has been relocated to xml-apis:xml-apis:1.0.b2.


[INFO] [jetspeed-deploy:deploy {execution: deploy}]
[INFO] Deploying to targetBaseDir c:\apache-tomcat-6.0.14
[INFO]   deploying to lib: portlet-api_2.0_spec-1.0.jar
[INFO]   deploying to lib: ccpp-1.0.jar
[INFO]   deploying to lib: jetspeed-api-2.2.0.jar
[INFO]   deploying to lib: jetspeed-commons-2.2.0.jar
[INFO]   deploying to lib: pluto-container-api-2.0.0.jar
[INFO]   deploying to lib: pluto-taglib-2.0.0.jar
[INFO]   deploying to lib: portals-bridges-common-1.0.4.jar
[INFO]   deploying to system: derby-10.3.2.1.jar
[INFO]   deploying to war: jetexpress (expanded)
[INFO]   deploying to context: jetexpress.xml
[INFO]   deploying to war: j2-admin.war
[INFO]   deploying to server-lib: apa-logging-1.0.jar
[INFO]   editing in server-conf: server.xml using ServerXMLConfigurer.verifyAndConfigureServerXML()
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 18 seconds
[INFO] Finished at: Thu Sep 03 14:12:06 MST 2009
[INFO] Final Memory: 10M/19M
[INFO] ------------------------------------------------------------------------
[INFO] ...SUCCESS.
[INFO] Executing target: deploy-pa dependent on [install-pa]
[INFO] Invoking target deploy-pa: C:\eclipseWorkspace\jetexpress\jetexpress-pa\jetspeed-mvn-pa-pom.xml
deploy
+ Error stacktraces are turned on.
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building Jetspeed-2 Maven Invoker Configuration for My Portlet Application
[INFO]    task-segment: [process-resources]
[INFO] ------------------------------------------------------------------------
[INFO] [jetspeed-deploy:deploy {execution: deploy}]
[INFO] Deploying to targetBaseDir c:\apache-tomcat-6.0.14
[INFO]   deploying to war: jetexpress-pa (infused, expanded)
Found WEB-INF/portlet.xml
Found web.xml
Attempting to add portlet.tld to war...
Adding portlet.tld to war...
Attempting to add portlet_2_0.tld to war...
Adding portlet_2_0.tld to war...
Creating war C:\DOCUME~1\SDahl\LOCALS~1\Temp\jetexpress-pa-1.0-SHAPSHOT.war.infused-905850823820826403
...
War C:\DOCUME~1\SDahl\LOCALS~1\Temp\jetexpress-pa-1.0-SHAPSHOT.war.infused-905850823820826403
created
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO] ------------------------------------------------------------------------
[INFO] Total time: < 1 second
[INFO] Finished at: Thu Sep 03 14:12:07 MST 2009
[INFO] Final Memory: 4M/8M
[INFO] ------------------------------------------------------------------------
[INFO] ...SUCCESS.
[INFO] Executing target: all dependent on [install,db,deploy-portal,deploy-pa] ONLY: all done
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESSFUL
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1 minute 58 seconds
[INFO] Finished at: Thu Sep 03 14:12:07 MST 2009
[INFO] Final Memory: 5M/9M
[INFO] ------------------------------------------------------------------------

Sandi

-----Original Message-----
From: David Sean Taylor [mailto:d.taylor@onehippo.com]
Sent: Thursday, September 03, 2009 1:36 PM
To: Jetspeed Developers List
Subject: Re: jetspeed tutorial error during build


On Sep 3, 2009, at 12:38 PM, Dahl, Sandra wrote:

> Thanks for the suggestions. I have moved tomcat, eclipse workspace
> and maven outside of the program files directory and they are
> located on c:\. I have also run with maven 2.0.10.
>
> I have resolved many issues and this was showing the log:
> Sep 3, 2009 8:42:43 AM
> org.apache.tomcat.util.digester.SetPropertiesRule begin
> WARNING: [SetPropertiesRule]{Server/Service/Engine/Host/Context}
> Setting property 'source' to 'org.eclipse.jst.jee.server:jetexpress'
> did not find a matching property
>
> Along with this:
> INFO: JetspeedContainerServlet: starting initialization of Portlet
> Application at: jetexpress-pa
> Sep 3, 2009 11:22:20 AM org.apache.catalina.core.ApplicationContext
> log
> INFO: JetspeedContainerServlet: Could not yet start portlet
> application at: jetexpress-pa. Starting back ground thread to start
> when the portal comes online.
>
This means the portal failed to start, and the portlet application
goes into a loop trying to register itself with the portal. The log
files will have the reasons for why the portal didn't start...


> I read the SetPropertiesRule warning above may be fixed by running
> on Tomcat 6.0.14. After trying this, the warning went away but the
> INFO messages still appear and the portal is not started. There are
> no additional error or warning messages in the log files.
>
> I'm wondering if I've missed a necessary step. The database I'm
> using is MS SqlServer and the database is already seeded (the same
> database works running against the Jetspeed demo). When
> mvn jetspeed:mvn -Dtarget=all
> is run, there is always an error in the database step and the script
> quits running.

If that fails no point in going on.

> mvn jetspeed:mvn -Dtarget=install runs successfully.
> I then run
> mvn jetspeed:mvn -Ddeploy-pa and deploy-portal
>
> 1. How can the create-schema.sql and drop-schema.sql scripts be
> replaced so target=all will run without error?

Something is failing in the database connection when these scripts are
run, it should print out to your console

> 2. How do I run all the steps in target=all except seeding the
> database?
> 3. Any other ideas on what is causing custom portal to not be
> deployed properly?


My guess is something not working in the database connection, maybe a
missing driver in the classpath, or even a problem with MS SQL scripts

>
> I don't know what else to try since there are no helpful messages in
> the log files.
>


The logs and console output should have enough information to help.
Lets take a step back and try using the default Derby database. If
that works then we can dig deeper into MS SQL

Edit the jetspeed-mvn-settings.xml and make these changes, note that
the database URL should point to some directory on your drive


<org.apache.jetspeed.production.jdbc.driver.groupId>org.apache.derby</
org.apache.jetspeed.production.jdbc.driver.groupId>
         <org.apache.jetspeed.production.jdbc.driver.artifactId>derby</
org.apache.jetspeed.production.jdbc.driver.artifactId>

         <org.apache.jetspeed.production.jdbc.driver.version>10.3.2.1</
org.apache.jetspeed.production.jdbc.driver.version>
         <org.apache.jetspeed.production.database.default.name>derby</
org.apache.jetspeed.production.database.default.name>
         <org.apache.jetspeed.production.database.url>jdbc:derby:/java/
database/test/jetspeed/derby/productiondb;create=true</
org.apache.jetspeed.production.database.url>

<
org
.apache
.jetspeed
.production.database.driver>org.apache.derby.jdbc.EmbeddedDriver</
org.apache.jetspeed.production.database.driver>

Then try running

mvn jetspeed:mvn -Dtarget=all

again, and when it bombs out check the command window for the full
message and send it to the list. You might need to increase the size
of your command buffer in windows

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Email secured by Check Point

Confidentiality Notice:
The information contained in this communication, including attachments, is privileged and
confidential.  It is intended only for the exclusive use of the addressee.  If the reader
is not the intended recipient, or the employee, or the agent responsible for delivering it
to the intended recipient, you are hereby notified that any dissemination, distribution or
copying of this communication is strictly prohibited.  If you have received this communication
in error, please notify us by return email or telephone immediately.  Thank you.

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message