portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ate Douma (JIRA)" <jetspeed-...@portals.apache.org>
Subject [jira] Commented: (JS2-991) Issues with Tomcat 6
Date Wed, 06 May 2009 20:08:30 GMT

    [ https://issues.apache.org/jira/browse/JS2-991?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12706573#action_12706573
] 

Ate Douma commented on JS2-991:
-------------------------------

Actually, I configure this a little different myself to get it more like Tomcat 5:

# unchanged default common.loader
common.loader=${catalina.home}/lib,${catalina.home}/lib/*.jar

# modified shared.loader (default empty)
shared.loader=${catalina.home}/shared/classes,${catalina.home}/shared/lib/*.jar

Maybe I should be using ${catalina.base} instead of ${catalina.home}, but I don't run multiple
instances so for me it doesn't make a difference.

Anyway, I wouldn't consider this a "bug" really. 
Nothing "broken" within Jetspeed for this, except that it just needs a little documentation
for the end-user IMO

> Issues with Tomcat 6
> --------------------
>
>                 Key: JS2-991
>                 URL: https://issues.apache.org/jira/browse/JS2-991
>             Project: Jetspeed 2
>          Issue Type: Bug
>          Components: Application servers
>    Affects Versions: 2.2.0
>         Environment: Jetspeed trunk 772355
> Apache Tomcat 6.0.18
>            Reporter: Niels van Kampenhout
>            Assignee: Randy Watler
>             Fix For: 2.2.0
>
>
> Tomcat 6 configuration needs to be adjusted for Jetspeed to start and run properly (where
Tomcat 5.5.26 works out of the box). In catalina.properties, 
> common.loader=${catalina.home}/lib,${catalina.home}/lib/*.jar
> must be changed into
> common.loader=${catalina.home}/lib,${catalina.home}/lib/*.jar,${catalina.base}/lib/*.jar,${catalina.base}/common/endorsed/*.jar,${catalina.base}/shared/lib/*.jar
> Otherwise exceptions occur when starting Tomcat:
> SEVERE: Error deploying configuration descriptor myportal.xml
> java.lang.NoClassDefFoundError: org/apache/jetspeed/security/User
> and
> SEVERE: error stopping 
> LifecycleException:  Pipeline has not been started
> To reproduce
> - download Tomcat 6.0.18 and unzip -- do not touch any configuration files
> - generate a custom portal with the maven archetype
> - edit Jetspeed configuration and set server directory to location of downloaded/unzipped
Tomcat 6.0.18
> - build and deploy custom portal (mvn jetspeed:mvn -Dtarget=all)
> - start Tomcat

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message