portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ate Douma (JIRA)" <jetspeed-...@portals.apache.org>
Subject [jira] Commented: (JS2-973) Running Jetspeed 2.2 on Websphere 6.1 / Oracle10
Date Mon, 11 May 2009 00:41:45 GMT

    [ https://issues.apache.org/jira/browse/JS2-973?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12707856#action_12707856
] 

Ate Douma commented on JS2-973:
-------------------------------

In contrary to my previous comments 3 and 2 items up, the com.ibm.ws.webcontainer.invokefilterscompatibility
fix for running WicketPortlet on Websphere can *not* be applied/defined in web.xml!
I made that incorrect assumption because I also (as also advised in IBM - PK33090) defined
this as global webcontainer custom property besides defining it in the j2-admin web.xml.

So, the only and required solution is the following:

  The com.ibm.ws.webcontainer.invokefilterscompatibility should be set to true
  through Application Servers -> <server> -> Web Container Settings -> Web
Container -> Custom Properties

Note: after doing this, Websphere needs to be restarted before this setting will take effect.

I'm going to remove again the incorrect definition from the j2-admin web.xml as it doesn't
have any effect by itself. 

> Running Jetspeed 2.2 on Websphere 6.1 / Oracle10
> ------------------------------------------------
>
>                 Key: JS2-973
>                 URL: https://issues.apache.org/jira/browse/JS2-973
>             Project: Jetspeed 2
>          Issue Type: Task
>    Affects Versions: 2.2.0
>            Reporter: Ate Douma
>            Assignee: Ate Douma
>             Fix For: 2.2.0
>
>
> Testing current Jetspeed 2.2-SNAPSHOT on Websphere 6.1 I;'ve encountered some issues
which I'm recording here for the record and/or as outstanding TODO tasks.
> - xml-apis jar: all the JAXP apis are now part of Java5+ and having this jar in WEB-INF/lib
causes problems on Websphere
>   TODO: remove/exclude this dependency in maven poms
> - stax-api-1.0.1.jar: this artifact (incorrectly) contains javax.xml.namespace.* classes
(QName specifically) which breaks JAXB on Websphere
>   TODO: upgrade to stax-api-1.0.2.jar which no longer contains the javax.xml.namespace
package
> - DDLUtils generates SEQUENCE seq_SECURITY_DOMAIN_DOMAIN_ID and TRIGGER trg_SECURITY_DOMAIN_DOMAIN_ID
for SECURITY_DOMAIN.UIX_DOMAIN_NAME for an Oracle database
>   During creation of the schema in the database the trigger code fails to be created.
However, both the sequence and the trigger are not needed anyway.
>   TODO: figure out how to disable the sequence and trigger generation from DDLUtils

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message