portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Timony, Michael" <Michael.Tim...@FMR.COM>
Subject RE: j2-admin u ser
Date Tue, 06 Feb 2007 21:32:21 GMT
Reboot, redeployed, restarted everything and now it's working. Maybe
there I had stale DB connections? Next I'm going to try with WebSphere
6.1 & Oracle.

David: I haven't seen that error message in my builds.

Mick


-----Original Message-----
From: David Sean Taylor [mailto:david@bluesunrise.com] 
Sent: Tuesday, February 06, 2007 4:25 PM
To: Jetspeed Developers List
Subject: Re: j2-admin u ser

Im seeing this error (on Maven only)

[java] javolution.xml.stream.XMLStreamException caused by
java.lang.ClassNotFoundException: title

I don't see this with the Maven-1 build

We recently changed an element in the MediaType serializer xsd from
"titel" to "title"
But I can't see why this would fail in Maven-2 build and not Maven-1 Im
thinking caching, or I don't know what./.

On Feb 6, 2007, at 1:07 PM, Timony, Michael wrote:

> OK, now it seems to be working, after redeploying for a 4th or 5th 
> time?
> Going to try and figure out why, but, I restarted the DB which may 
> have had something to do with it?
>
> Mick
>
>
> -----Original Message-----
> From: Timony, Michael
> Sent: Tuesday, February 06, 2007 3:51 PM
> To: Timony, Michael; 'David Sean Taylor'; 'Jetspeed Developers List'; 
> Moynihan, Michael A
> Subject: RE: j2-admin u ser
>
>
> The mailer daemon didn't like the size of those files.  Trying again 
> with 2 separate e-mails.
>
> See attached cat.out which is the output from Tomcat.
>
>
> -----Original Message-----
> From: Timony, Michael
> Sent: Tuesday, February 06, 2007 3:46 PM
> To: Timony, Michael; 'David Sean Taylor'; 'Jetspeed Developers List'; 
> Moynihan, Michael A
> Subject: RE: j2-admin u ser
>
> Fails when I change the DB to be Oracle. Here's what we've been doing 
> to get it to work with Oracle:
>
> Edit datasource.xml which can be found at:
> artifactId\etag-portal\portal\target\artifactId-portal-version\WEB-
> INF\a
> ssembly\boot
>
> In our example that will be:
>
> etag-portal-test-1\portal\target\etag-portal-test-1-portal-1.0\WEB-
> INF\a
> ssembly\boot
>
> Replace the JNDI JetspeedDS bean at the start of the file with the 
> JetspeedDS at the bottom of the file. In other words replace the 
> following code:
>
>  <bean id="JetspeedDS"
> class="org.springframework.jndi.JndiObjectFactoryBean">
>      <property name="resourceRef"><value>false</value></property>
>      <property name="jndiName">
>         <value>java:comp/env/jdbc/jetspeed</value>
>      </property>
>  </bean>
>
> With this basic Datasource bean, change as necessary for your
> environment:
>
>  <bean id="JetspeedDS" class="org.apache.commons.dbcp.BasicDataSource"
> destroy-method="close">
>     <property name="driverClassName">
>        <value>oracle.jdbc.OracleDriver</value>
>     </property>
>     <property name="url">
>        <value>jdbc:oracle:thin:@127.0.0.1:1521:XE</value>
>     </property>
>     <property name="username">
>        <value>USERNAME</value>
>     </property>
>     <property name="password">
>        <value>PASSWORD</value>
>     </property>
>  </bean>
>
>
> It builds and deploys successfully, but the portal won't start. See 
> the attached 2 files for error messages. The first file, cat.out,  is 
> the output from tomcat (for some reason my Tomcat on Windows isn't 
> writing to the logs files just to stdout). The second file is 
> jetspeed.log from webapps/portal/logs.
>
> So any ideas?
>
> Mick
>
> -----Original Message-----
> From: Timony, Michael
> Sent: Tuesday, February 06, 2007 2:37 PM
> To: Timony, Michael; 'David Sean Taylor'; 'Jetspeed Developers List'; 
> Moynihan, Michael A
> Subject: RE: j2-admin user
>
> That build correctly, except for some warnings about some missing pom 
> files (see the attached file). Starting up tomcat it looks like it 
> start correctly with Tomcat & Derby. Next, I'm going to try Tomcat & 
> Oracle and see what happens.
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
> For additional commands, e-mail: jetspeed-dev-help@portals.apache.org
>
>

--
David Sean Taylor
Bluesunrise Software
david@bluesunrise.com
[office] +01 707 773-4646
[mobile] +01 707 529 9194



---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@portals.apache.org
For additional commands, e-mail: jetspeed-dev-help@portals.apache.org


Mime
View raw message