portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jean-charles.jaboui...@bull.net
Subject Re: Re: JdbcConnectionDescriptor problem
Date Thu, 25 Nov 2004 07:44:46 GMT

Yes That's the problem. But I declared an appropriate resource-ref in
jonas-web.xml
Where is define the jndi Context and the datasource name ?

thanks for answer

Jabouille jean charles





|---------+--------------------------->
|         |           David Jencks    |
|         |           <djencks@gluecod|
|         |           e.com>          |
|         |                           |
|         |           24/11/2004 17:23|
|         |           Veuillez        |
|         |           répondre à      |
|         |           "Jetspeed       |
|         |           Developers List"|
|         |                           |
|---------+--------------------------->
  >---------------------------------------------------------------------------------------------------------------|
  |                                                                                      
                        |
  |        Pour :   "Jetspeed Developers List" <jetspeed-dev@jakarta.apache.org>   
                              |
  |        cc :                                                                          
                        |
  |        Objet :  Re: JdbcConnectionDescriptor problem                                 
                        |
  >---------------------------------------------------------------------------------------------------------------|



I don't remember the details, but when I was integrating jetspeed into
geronimo I had this problem and it was caused by the component jndi
context (java:comp/env...) not being set up properly before a servlets
init method was called.  After fixing this geronimo bug and setting up
an appropriate resource-ref I was able to get Jetspeed to work.

david jencks

On Nov 24, 2004, at 7:23 AM, jean-charles.jabouille@bull.net wrote:

> Hi,
>
> I try to migrate jetzspeed2 for Jonas 4.1.4.
> I have a JNDI problem when OJB try to look up the datasource..
> I modified the ojb class in order to debug the problem.
>
> here is the error during the jetspeed2 deployement
>
> - Jetspeed Starting Initialization...
> - JetspeedServlet identifying web application root...
> - JetspeedServlet identifed web application root as
> /home/jabouijc/JONAS_4_1_4/work/webapps/jonas/jetspeed/
> - JetspeedServlet attempting to create the  portlet engine...
> - Jetspeed environment attempting to initialize portal Engine...
> JNDI System Property flag null
> INITIAL_CONTEXT_FACTORY
> org.objectweb.carol.jndi.spi.MultiOrbInitialContextFactory
> PROVIDER_URL null
> URL_PKG_PREFIXES org.objectweb.jonas.naming
> JCD
> REPRESENTATIONorg.apache.ojb.broker.metadata.JdbcConnectionDescriptor@1
> ca7841[
Mime
View raw message