portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Randy Watler <rwat...@finali.com>
Subject Re: [PATCH] [J2] Page Navigation Tabs Decorators
Date Thu, 02 Sep 2004 20:45:44 GMT
David/Scott:

David Sean Taylor wrote:

> Randy Watler wrote:
>
>> David,
>>
>>> Just discovered during testing that the decorators are not correctly 
>>> displaying the background in the title bar in maximize mode.
>>> Are you seeing that too?
>>>
>>
>> I am not seeing any odd behavior in the portlet title bars in 
>> maximized mode. Which browser are you using?
>>
> Mozilla (Firefox)
> Internet Explorer 6
>
> same behavior on both
> The title bar background is white, thus you dont really see the title bar
> Perhaps you forgot to send a patched file, or I missed one? 

No, neither. This appears to be because the portlet css stylesheet is 
now not linked into the document in maximized mode.

Perhaps this has to do with the recent changes in 
PageAggregatorImpl/PortletAggregatorImpl that moved the "cssUrls" 
setting from a context session to a plain context attribute? I am still 
trying to track down how the setting makes its way ino the renderRequest 
object used by the decorator via the JetspeedPowerTool... I am guessing 
someone more familiar with the core can find the problem more quickly?

Still looking anyway,

Randy Watler



---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


Mime
View raw message