portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raphaël Luta <raph...@apache.org>
Subject [J2] Maven version required to build J2 ?
Date Mon, 29 Mar 2004 08:13:36 GMT
I spent a very frustating week-end trying to build J2 and while
I finally managed to get there, I found several issues with Maven
along the way.

First my dev setup is:
windows 2000 SP4
jsdk 1.4.2_03
tomcat 4.1.24

I had maven 1.0-rc1 installed and kept getting errors in the torque
generation tasks about log4j not finding its appender definition.
So I decided to do a full reinstall of Maven using the latest rc2
binary.
Bad idea! The rc2 seems not to package a torque plugin anymore and
the goal jar:install fails because of some issues with the java
plugin (I've not bothered to look more in-depth into it...)

So to get a clean build of J2 I had to do the following:
Use Maven rc2 with the torque plugin bundled with beta 10 and the
java plugin bundled with rc1 !

My question is: am I the only one with this issue with the Maven
release candidates ?
If not, I think we should update the getting started document
to specify which version of Maven exactly works for building J2.

I must also say that I'm quite uncomfortable with this Maven dependency
as it seems to me that it's pretty much like the Turbine of old: a
moving target you can't really depend upon and it's so damn SLOW !

Anyway, just my 2 cents.

-- 
Raphaël Luta - raphael@apache.org
Apache Jetspeed - Enterprise Portal in Java
http://jakarta.apache.org/jetspeed/


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


Mime
View raw message