portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Glenn R. Golden" <ggol...@umich.edu>
Subject Re: [Pluto]: how to add a portlet
Date Thu, 02 Oct 2003 13:15:22 GMT
I'll answer this - I'm not sure this is the best or only way, but it 
works...

To add portlets to pluto's portal, edit:

PLUTO/war/WEB-INF/data/portletentityregistry.xml

Then edit:

PLUTO/war/WEB-INF/data/pageregistry.xml

To add them to the set of pages, etc, displayed.

If you modify these in the source area, you have to re-install pluto.  
You can also edit them in the deployed webapp.

- Glenn

On Wednesday, October 1, 2003, at 11:42  PM, Glenn R. Golden wrote:

> I've checked out, built and installed Pluto, and the test portlet 
> works.
>
> I've created a .war with some sample portlets from Sun, and placed 
> this in the pluto/portlets directory.
> When I install pluto, it picks that up, makes a webapp in tomcat for 
> it, and seems happy.
>
> But when I visit pluto's portal in my browser at 
> localhost/pluto/portal, it just shows the "test" in the left menu...
>
> So, if we add a portlet to pluto, how do we get to see it in pluto?
>
> Thanks.
>
> - Glenn
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


Mime
View raw message