portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 20311] New: - NullPointerException in org.apache.jetspeed.om.registry.base.BasePortletInfoEntry when creating a new portlet
Date Wed, 28 May 2003 18:08:46 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://nagoya.apache.org/bugzilla/show_bug.cgi?id=20311>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://nagoya.apache.org/bugzilla/show_bug.cgi?id=20311

NullPointerException in org.apache.jetspeed.om.registry.base.BasePortletInfoEntry when creating
a new portlet

           Summary: NullPointerException in
                    org.apache.jetspeed.om.registry.base.BasePortletInfoEntr
                    y when creating a new portlet
           Product: Jetspeed
           Version: 1.4b4-dev / CVS
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: Critical
          Priority: Other
         Component: Registry
        AssignedTo: jetspeed-dev@jakarta.apache.org
        ReportedBy: jason@omnicoders.com


The mediasIdx is initially set to null and isn't guaranteed to be 
initialized.  The only methods that initialize this variable are listMediaTypes
() and hasMediaType().  

Therefore, if you try to create a NEW portlet and call addMediaType(String), 
you get a NPE.

WORKAROUND:  Even though its a new portlet, calling a check to hasMediaType() 
properly initializes the mediasIdx Map and you can then successfully add the 
new portlet.  The only way to know this workaround is to dig through the 
source code!

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


Mime
View raw message