portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ahmed shaheen" <ahmed_...@hotmail.com>
Subject jetspeed arabization problem
Date Thu, 20 Feb 2003 15:52:12 GMT
Hi all

we are trying now to arabize jetspeed and we are facing some problems.
We are using jetspeed1.4b3 with Tomcat 4.1.12 On WinXP
Our steps were:
1) writing a (JetspeedLocalization_ar.properties) file with windows 
notepad(ansi encoding)
2) adding some changes to the LocalizationTool.class to return the string 
with WINDOWS-1256 encoding
3) changing the encodings and charactersets in all files : jr.p tr.p 
fulcrum.p velocity.p
these steps were successfully done and arabic strings appeared correctlty.

then we tried to arabize the content retrieved from XML files As .psml files 
(eg. tabs' titles in tabpane layout)
but it seems that there is a problem in reading and writing arabic in XML 
files. Did anybody face a similar problem .. we think that the problem
in the XML APIs that deals with files.

we have done a lot of trials but where system dependent (change the language 
in RegionalSittings to Ar)
and not working perfectly because it conflicts with previous working steps.

Anyhelp will be appreciated.

Ahmed Shaheen
NileClix(www.nileclix.com.eg)





_________________________________________________________________
Add photos to your messages with MSN 8. Get 2 months FREE*. 
http://join.msn.com/?page=features/featuredemail


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


Mime
View raw message