portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Shinsuke SUGAYA <shins...@yahoo.co.jp>
Subject Re: jetspeed arabization problem
Date Fri, 21 Feb 2003 01:27:00 GMT
 --- ahmed shaheen <ahmed_shn@hotmail.com>
> Hi all
> 
> we are trying now to arabize jetspeed and we are facing some problems.
> We are using jetspeed1.4b3 with Tomcat 4.1.12 On WinXP
> Our steps were:
> 1) writing a (JetspeedLocalization_ar.properties) file with windows 
> notepad(ansi encoding)
> 2) adding some changes to the LocalizationTool.class to return the string 
> with WINDOWS-1256 encoding
> 3) changing the encodings and charactersets in all files : jr.p tr.p 
> fulcrum.p velocity.p
> these steps were successfully done and arabic strings appeared correctlty.
> 
> then we tried to arabize the content retrieved from XML files As .psml files 
> (eg. tabs' titles in tabpane layout)
> but it seems that there is a problem in reading and writing arabic in XML 
> files. Did anybody face a similar problem .. we think that the problem
> in the XML APIs that deals with files.

I think it is the following bug.

Encoding of the registry files: always default system encoding?
http://issues.apache.org/bugzilla/show_bug.cgi?id=13286

Thanks,
 shinsuke

> we have done a lot of trials but where system dependent (change the language 
> in RegionalSittings to Ar)
> and not working perfectly because it conflicts with previous working steps.
> 
> Anyhelp will be appreciated.
> 
> Ahmed Shaheen
> NileClix(www.nileclix.com.eg)


__________________________________________________
Do You Yahoo!?
Yahoo! BB is Broadband by Yahoo!
http://bb.yahoo.co.jp/


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


Mime
View raw message