portals-jetspeed-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Kruse <Kr...@expertcity.com>
Subject RE: Confirmation email contains incorrect secret key
Date Mon, 02 Apr 2001 18:33:27 GMT
Yes I've had that issue. I have SuSE 7.1 Tomcat 3.2.x and the Jetspeed WAR
file from the site. I looked in the database to find the secret key, and
pulled the key from there. I checked the log file, and value was missing
from the TURBINE_PERMISSION (or was it _ROLE_PERMISSION), but I'm not sure
if that was related.



-----Original Message-----
From: Dave Carlson [mailto:dcarlson@ontogenics.com]
Sent: Sunday, April 01, 2001 4:59 PM
To: jetspeed-dev@jakarta.apache.org
Subject: Re: Confirmation email contains incorrect secret key


Edward,
Thanks for the reply.  I rebuilt Jetspeed from a clean CVS checkout on
Friday morning, so how can I "reinstall Turbine code from the tar and
reload a new Jetspeed from the war"?  If the DB is damaged, then it must be
damaged in the CVS.

Anyone else with this mail problem?  I have a simple installation: Redhat
7.0 Linux, Tomcat 3.2.1, and a new build of Jetspeed.  The mail server
(Linux) seems to be configured and working properly, because I do get the
email.  The email message looks as follows:

=========================================
Welcome to Jetspeed

Your new account has been created.

Your secret key is:

null

You can go to the following URL to confirm your account:

<http://test.ontogenics.com/jetspeed/portal/screen/ConfirmRegistration/user
name/dcarlson/secretkey/null/nextscreen/null>

=========================================

----- Original Message -----
From: "Edward M. Goldberg" <emg@EdwardMGoldberg.com>
To: <jetspeed-dev@jakarta.apache.org>
Sent: Sunday, April 01, 2001 12:23 AM
Subject: Re: Confirmation email contains incorrect secret key


> I had the same problem a while back.  I asked the list
> and have no reply to date.
>
> What I did was to re-install the turbine code from
> the tar and reload a new jetspeed from the war.
>
> This made the problem go away for me.  I never found
> out why the DB was damaged.   The code does not check
> for a key of null returned from the DB query.  So I
> have to assume that the DB returned null for that account
> and the code passed it on to the e-mail..
>
> e.m.g.
>
>
> Dave Carlson wrote:
>
> > The confirmation email for new accounts is working, but the email
contains
> > a secret key "null".  If I look in the user database and get the actual
> > secret key value, then I can confirm succesfully.  Does anyone else
have
> > this problem?
> >
> > Thanks!
> >   Dave
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
> > For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: jetspeed-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: jetspeed-dev-help@jakarta.apache.org


Mime
View raw message