phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pedro Boado <pedro.bo...@gmail.com>
Subject Re: modifiy parcel to work with cdh 5.16
Date Fri, 07 Dec 2018 10:58:39 GMT
Hi,

change cdh version for dependencies in pom.xml and recompile ( mvn clean
package, you'll find your parcels under module phoenix-server) . But do
this at your own risk! Potentially a number of IT tests won't pass.

Saying that both run same HBase 1.2 is quite imprecise, Cloudera keeps
applying certain upstream changes to new CDH versions. This means that one
of this changes could break something. To have more certainty run all IT (
mvn clean verify ) before building the parcels.

Cheers,
Pedro.

On Fri, 7 Dec 2018, 10:45 anung <anung.anindita.basuki@gmail.com wrote:

> Hi All,
>
> I have a cluster with CDH 5.16.
> Since CDH 5.16 and CDH 5.14 have the same underlying HBase version (1.2.0).
> How to modify the existing parcels dependencies on CDH 5.14 to work
> with CDH 5.16?
> I tried to modified the parcel.json but it does not work :(
>
> Thank you
>
> BR,
> Anung
>

Mime
View raw message