You can do that through the hbase shell doing a

hbase(main):011:0> truncate 'SYSTEM.MUTEX'



On 17 December 2017 at 22:01, Flavio Pompermaier <pompermaier@okkam.it> wrote:
I've got Phoenix 4.13 both on client and server side..How can I truncate Mutex table? I don't have any..

On Sun, Dec 17, 2017 at 10:29 PM, Ethan <ewang@apache.org> wrote:
Hi Flavio,

What is your server side Phoenix jar version and client side Phoenix version, note that server side has to have a higher version than client side.

Another note, I got a similar issue the other day. I solved it by truncate system Mutex table. Hope it helps yours too.

Thanks,


On December 16, 2017 at 3:23:47 PM, Flavio Pompermaier (pompermaier@okkam.it) wrote:

Hi to all, 
I've recently updated my Cloudera + Phoenix from CDH 5.9 + 4.7 to CDH 5.11.2 + 4.13 but now I can't connect with Phoenix anymore. When I run phoenix-sqlline.sql I get:

WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable
Error: Cluster is being concurrently upgraded from 4.7.x to 4.13.x. Please retry establishing connection. (state=INT12,code=2010)
org.apache.phoenix.exception.UpgradeInProgressException: Cluster is being concurrently upgraded from 4.7.x to 4.13.x. Please retry establishing connection.
at org.apache.phoenix.query.ConnectionQueryServicesImpl.acquireUpgradeMutex(ConnectionQueryServicesImpl.java:3231)
at org.apache.phoenix.query.ConnectionQueryServicesImpl.upgradeSystemTables(ConnectionQueryServicesImpl.java:2615)
at org.apache.phoenix.query.ConnectionQueryServicesImpl$12.call(ConnectionQueryServicesImpl.java:2478)
at org.apache.phoenix.query.ConnectionQueryServicesImpl$12.call(ConnectionQueryServicesImpl.java:2384)
at org.apache.phoenix.util.PhoenixContextExecutor.call(PhoenixContextExecutor.java:76)
at org.apache.phoenix.query.ConnectionQueryServicesImpl.init(ConnectionQueryServicesImpl.java:2384)
at org.apache.phoenix.jdbc.PhoenixDriver.getConnectionQueryServices(PhoenixDriver.java:255)
at org.apache.phoenix.jdbc.PhoenixEmbeddedDriver.createConnection(PhoenixEmbeddedDriver.java:150)
at org.apache.phoenix.jdbc.PhoenixDriver.connect(PhoenixDriver.java:221)
at sqlline.DatabaseConnection.connect(DatabaseConnection.java:157)
at sqlline.DatabaseConnection.getConnection(DatabaseConnection.java:203)
at sqlline.Commands.connect(Commands.java:1064)
at sqlline.Commands.connect(Commands.java:996)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:606)
at sqlline.ReflectiveCommandHandler.execute(ReflectiveCommandHandler.java:38)
at sqlline.SqlLine.dispatch(SqlLine.java:809)
at sqlline.SqlLine.initArgs(SqlLine.java:588)
at sqlline.SqlLine.begin(SqlLine.java:661)
at sqlline.SqlLine.start(SqlLine.java:398)
at sqlline.SqlLine.main(SqlLine.java:291)
sqlline version 1.2.0

How can I repair my installation? I can't find any log nor anything strange in the SYSTEM.CATALOG HBase table..

Thanks in advance,
Flavio



--
Flavio Pompermaier
Development Department

OKKAM S.r.l.
Tel. +(39) 0461 041809



--
Un saludo.
Pedro Boado.