phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <els...@apache.org>
Subject Re: Mixed client/server versions
Date Thu, 21 Sep 2017 15:08:17 GMT
Hi there,

In general, no, you should not see issues. We (really, Avatica -- the 
project "powering" PQS) strives to make changes to the wire-protocol in 
a backwards compatible manner. Avatica also includes a basic framework 
to do forward and backwards compatibility testing.

You are more likely to run into issues where the 4.7 client is simply 
doing the wrong thing. There have been one or two issues like these. 
CALCITE-1103 is one that I can find easily (truncation around decimal 
datatypes).

On 9/19/17 2:16 PM, Yan Koyfman wrote:
> Would we run into issues when working with a newer PQS server (4.11) and 
> a 4.7 client library?  In general I'm curious if there is backward 
> compatibility between mixed server / client versions.
> 
> Thanks
> 

Mime
View raw message