phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Will Xu <...@hortonworks.com>
Subject Re: I cant get the latest phoenix to work in docker
Date Mon, 01 May 2017 17:25:13 GMT
If you run
$> hbase zkcli
$>ls /

You should be able to see [zookeeper, hbase]
If you don’t see this, then it means hbase service is not started or did not properly register
with zookeeper.

Best thing to do would be remove the images of avapno/apache-phoenix and try pulling the docker
image again.

I used this command and it worked
docker run -it --name phoenix -p 8765:8765 avapno/apache-phoenix

Regards,
Will
From: Cheyenne Forbes <cheyenne.osanu.forbes@gmail.com>
Reply-To: "user@phoenix.apache.org" <user@phoenix.apache.org>
Date: Saturday, April 29, 2017 at 1:35 PM
To: "user@phoenix.apache.org" <user@phoenix.apache.org>
Subject: I cant get the latest phoenix to work in docker

docker file and other files: https://github.com/CheyenneForbes/docker-apache-phoenix
the connection just hangs when I try to use the query server and if I run any command in hbase
shell I get "ERROR: Can't get master address from ZooKeeper; znode data == null"

Regards,

Cheyenne O. Forbes
Mime
View raw message