phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: Upgrade Phoenix version on HDP 2.4
Date Fri, 19 May 2017 15:52:14 GMT
I definitely understand and share your concern. I can also say that we 
are aware of this issue, and are trying to stay on top of it as best as 
we can.

I cannot, however, commit to any sort of timeframe on behalf of the company.

James Taylor wrote:
> But hopefully Hortonworks hears (from you and many others) that you'd
> like to see HDP move to a newer version of Phoenix. The 4.7 release is
> four releases back from the current 4.10 release.
>
> Any ballpark timeframe for an HDP release with the latest Phoenix release?
>
>
> On Fri, May 19, 2017 at 7:56 AM Josh Elser <josh.elser@gmail.com
> <mailto:josh.elser@gmail.com>> wrote:
>
>     Hi Bernard,
>
>     (wearing my Hortonworks hat)
>
>     No, there is no way for you to in-place upgrade Phoenix. We do a
>     significant amount of compatibility testing for the versions of all
>     components shipped in HDP.
>
>     Please note that the version of Phoenix that is shipped inside HDP is
>     *based* on an Apache Phoenix release, not an exact Apache Phoenix
>     release. You would be on an island by yourself if you tried to replace
>     jars with a different version. I'd be very surprised if you even had
>     basic functionality :)
>
>     Bernard Quizon wrote:
>      > Hi,
>      >
>      > We're on HDP 2.4 with Phoenix version 4.4.0-Hbase-1.1, is there a way
>      > for us to upgrade to 4.10.0-Hbase-1.1?
>      > I know HDP 2.6 has version 4.7.0 but we're targeting the latest
>     version.
>      >
>      >
>      > Thanks!
>

Mime
View raw message