phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: Unable to delete from table
Date Sat, 29 Apr 2017 22:31:51 GMT
AFAIK, autoCommit should be working in that version with PQS.

Did you try James' suggestion of calling !commit?

On Fri, Apr 28, 2017 at 6:04 PM, Michael Young <yomaiquin@gmail.com> wrote:
> Update:
>
> The delete issue happens when I connect via the Phoenix Query Server but
> works fine when I connect to the phoenix client on port 2181 (I was able to
> delete all records).  Auto-commit is true.
>
> Here's what I see with PQS:
>
> /usr/hdp/2.5.0.0-1245/phoenix/bin/sqlline-thin.py http://mypqs:8765
>
> Setting property: [incremental, false]
> Setting property: [isolation, TRANSACTION_READ_COMMITTED]
> issuing: !connect
> jdbc:phoenix:thin:url=http://lax1rh003.touchcommerce.com:8765;serialization=PROTOBUF
> none none org.apache.phoenix.queryserver.client.Driver
> Connecting to
> jdbc:phoenix:thin:url=http://lax1rh003.touchcommerce.com:8765;serialization=PROTOBUF
> SLF4J: Class path contains multiple SLF4J bindings.
> SLF4J: Found binding in
> [jar:file:/usr/hdp/2.5.0.0-1245/phoenix/phoenix-4.7.0.2.5.0.0-1245-thin-client.jar!/org/slf4j/impl/StaticLoggerBinder.class]
> SLF4J: Found binding in
> [jar:file:/usr/hdp/2.5.0.0-1245/hadoop/lib/slf4j-log4j12-1.7.10.jar!/org/slf4j/impl/StaticLoggerBinder.class]
> SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an
> explanation.
> SLF4J: Actual binding is of type [org.slf4j.impl.Log4jLoggerFactory]
> Connected to: Apache Phoenix (version unknown version)
> Driver: Phoenix Remote JDBC Driver (version unknown version)
> Autocommit status: true
> Transaction isolation: TRANSACTION_READ_COMMITTED
> Building list of tables and columns for tab-completion (set fastconnect to
> true to skip)...
> 7815/7815 (100%) Done
> Done
> sqlline version 1.1.8
>
>
>
> On Fri, Apr 28, 2017 at 1:13 PM, James Taylor <jamestaylor@apache.org>
> wrote:
>>
>> Did you commit the data? I'd recommend turning auto commit on for the
>> connection before running the delete statement.
>>
>> Thanks,
>> James
>>
>> On Fri, Apr 28, 2017 at 12:36 PM, Michael Young <yomaiquin@gmail.com>
>> wrote:
>>>
>>> This is probably a newbie question, but has anyone run across a case
>>> where a simple 'delete from tbl' fails to work?
>>>
>>> my_tmp_table has 29,728 rows
>>>
>>> I run:
>>> delete from my_tmp_table;
>>> 29,728 rows affected (0.08 seconds)
>>>
>>> select count(*) from my_tmp_table;
>>> 'COUNT(1)'
>>> '29728'
>>>
>>> No rows were deleted from this table.  My table doesn't have
>>> IMMUTABLE_ROWS=true, but even if it did I would expect delete to work.
>>>
>>> We use phoenix-4.7.0.2.5.0.0-1245 in HDP 2.5 release.
>>>
>>> Are there any checks I can do to identify the cause (without restarting
>>> hbase, that is)?
>>>
>>> -Michael
>>>
>>>
>>
>

Mime
View raw message