It would be nice if the actual Phoenix website mentioned things like this, instead of having to look through blog posts, mailing lists, the issue tracker, and whatever search-hadoop is...

On Tue, Feb 7, 2017 at 9:52 AM, Ankit Singhal <ankitsinghal59@gmail.com> wrote:
The relevant thread where the decision was made to drop HBase 1.0 support from v4.9 onwards.
http://search-hadoop.com/m/Phoenix/9UY0h21AGFh2sgGFK?subj=Re+DISCUSS+Drop+HBase+1+0+support+for+4+9



On Tue, Feb 7, 2017 at 8:13 PM, Mark Heppner <heppner.mark@gmail.com> wrote:
Pedro,
I can't answer your question, but if you look at the blog announcement for 4.9, they say it's compatible with HBase 0.98/1.1/1.2:
    https://blogs.apache.org/phoenix/entry/announcing_phoenix_4_9_released

The announcements for 4.8 and lower says HBase 0.98/1.0/1.1/1.2:
   https://blogs.apache.org/phoenix/entry/announcing_phoenix_4_8_released

If you look at the Maven repo (I think it's separately maintained), there's also no bundle with HBase 1.0:
    https://mvnrepository.com/artifact/org.apache.phoenix/phoenix-queryserver

Maybe they silently dropped support for 1.0? Of course there's nothing on the actual release notes, so I'm not sure:
    https://phoenix.apache.org/release_notes.html



On Mon, Feb 6, 2017 at 6:29 PM, Pedro Boado <pedro.boado@gmail.com> wrote:
Hi, 

I've being looking at Phoenix 4.9 and HBase supported versions and I'm missing support for HBase 1.0  . We are running a previous version of Phoenix on cdh 5.5.4, we regularly recompile Phoenix with our vendor specific dependencies - with no significant issues - but now without this support we are stuck at 4.8.2  until we upgrade our cluster to HBase 1.1/1.2

Is there any plan to support HBase 1.0 again on this (or newer) versions?

Thanks for a great work!

Regards.

--
Un saludo.
Pedro Boado.



--
Mark Heppner




--
Mark Heppner