phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Purtell <andrew.purt...@gmail.com>
Subject Re:
Date Thu, 16 Feb 2017 16:23:38 GMT
Phoenix has to be patched to work with Cloudera's HBase derivative. You might try https://github.com/chiastic-security/phoenix-for-cloudera/tree/4.9-HBase-1.2-cdh5.9

Check out this tree and build. The procedure for building is the same (https://phoenix.apache.org/building.html)
This will pick up Cloudera's artifacts and produce a binary compatible result. 


> On Feb 16, 2017, at 8:07 AM, Marcin Januszkiewicz <katamaran666@gmail.com> wrote:
> 
> Are you maybe using a HBase distribution from a vendor? I had similar errors when trying
to use Phoenix 4.9 on the Cloudera build of HBase.
> 
>> On 2017-02-16 10:46 (+0100), "Nimrod Oren"<nimrod.oren@veracity-group.com>
wrote: 
>> I didn't mean to sound rude.
>> 
>> I created another table using phoenix-sqlline according to the documentation:
>> 
>> CREATE TABLE IF NOT EXISTS TEST_SAVE_NEW (
>>      IMEI VARCHAR NOT NULL PRIMARY KEY,
>>      END_LATITUDE VARCHAR);
>> 
>> Still getting the same issue.
>> 

Mime
View raw message