phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <els...@apache.org>
Subject Re: Can I use protobuf2 with Phoenix instead of protobuf3?
Date Wed, 15 Feb 2017 17:28:47 GMT
This is a non-issue...

Avatica's use of protobuf is completely shaded (relocated classes). You 
can use whatever version of protobuf in your client application you'd like.

Mark Heppner wrote:
> If Cheyenne is talking about the query server, I'm not sure where you're
> getting that from, Ted. It doesn't directly depend on protobufs, it's
> pulled in from Avatica:
> https://github.com/apache/phoenix/blob/v4.9.0-HBase-1.2/phoenix-queryserver/pom.xml
> Avatica does use protobuf 3:
> https://github.com/apache/calcite/blob/calcite-avatica-1.9.0/avatica/pom.xml
>
> Cheyenne, could you try building with an earlier version of Avatica?
>
> On Mon, Feb 13, 2017 at 8:41 PM, Ted Yu <yuzhihong@gmail.com
> <mailto:yuzhihong@gmail.com>> wrote:
>
>     Phoenix uses protobuf 2.5
>     From pom.xml :
>
>     <protobuf-java.version>2.5.0</protobuf-java.version>
>
>     FYI
>
>     On Mon, Feb 13, 2017 at 4:52 PM, Cheyenne Forbes
>     <cheyenne.osanu.forbes@gmail.com
>     <mailto:cheyenne.osanu.forbes@gmail.com>> wrote:
>
>         my project highly depends on protobuf2, can I tell phoenix which
>         version of protobuf to read with when I am sending a request?
>
>
>
>
>
> --
> Mark Heppner

Mime
View raw message