phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "lk_phoenix"<lk_phoe...@163.com>
Subject Re: Re: Apache Spark Plugin dosn't support spark2.0
Date Mon, 05 Dec 2016 08:14:10 GMT
thanks a lot.

2016-12-05 

lk_phoenix 



发件人:Dequn Zhang <d.q.zhang.chn@gmail.com>
发送时间:2016-12-05 15:53
主题:Re: Apache Spark Plugin dosn't support spark2.0
收件人:"user"<user@phoenix.apache.org>
抄送:

Spark changed DataFrame definition from 2.x , it’s not compatible with 1.x and Phoenix Spark
Interpreter was developed with Spark 1.x API, so , until now, U can use Phoenix JDBC instead
in Spark 2.0. 


You can loot at this JIRA.


https://issues.apache.org/jira/browse/PHOENIX-3333


On 5 December 2016 at 15:45:05, lk_phoenix (lk_phoenix@163.com) wrote:
hi,all:
   when I try spark plugin with phoenix 4.9,I got error:

java.lang.NoClassDefFoundError: org/apache/spark/sql/DataFrame 

2016-12-05


lk_phoenix
Mime
View raw message