phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dequn Zhang <d.q.zhang....@gmail.com>
Subject Re: Apache Spark Plugin dosn't support spark2.0
Date Mon, 05 Dec 2016 07:53:47 GMT
Spark changed DataFrame definition from 2.x , it’s not compatible with 1.x
and Phoenix Spark Interpreter was developed with Spark 1.x API, so , until
now, U can use Phoenix JDBC instead in Spark 2.0.

You can loot at this JIRA.

https://issues.apache.org/jira/browse/PHOENIX-3333

On 5 December 2016 at 15:45:05, lk_phoenix (lk_phoenix@163.com) wrote:

hi,all:
   when I try spark plugin with phoenix 4.9,I got error:

java.lang.NoClassDefFoundError: org/apache/spark/sql/DataFrame

2016-12-05
------------------------------
lk_phoenix

Mime
View raw message