phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Terrell <sterr...@oculus360.us>
Subject Re: Error while attempting join query
Date Thu, 07 Apr 2016 18:48:09 GMT
OK, check out
http://stackoverflow.com/questions/32208549/how-to-use-newer-versions-of-hbase-on-amazon-elastic-mapreduce
.  Worked for me!

I'm using EMR AMI.3.10.0 .

On Thu, Apr 7, 2016 at 1:00 PM, James Taylor <jamestaylor@apache.org> wrote:

> I'm interested in the "how". Thanks for sharing this info, Steve.
>
>     James
>
> On Thu, Apr 7, 2016 at 8:30 AM, Steve Terrell <sterrell@oculus360.us>
> wrote:
>
>> I've been successful at running HBase 0.98.15 and Phoenix 4.6.0 on EMR.
>> Found someone else's solution for this on the internet.  Been working fine
>> for months.  Downside is loss of some Amazon EMR tools like HBase backups
>> to S3.  If anyone else is interested in the "how", post a new email to this
>> mailing list with a new subject heading.
>>
>> Thanks,
>>     Steve
>>
>> On Wed, Apr 6, 2016 at 9:22 PM, Deepak Gopalakrishnan <dgkris@gmail.com>
>> wrote:
>>
>>> Hello All,
>>>
>>> I apologise if I sounded persistent. It was not my intention at all, was
>>> just adding more detail to the thread in hope of getting a solution.
>>>
>>> I completely understand the issue, but Amazon EMR does not support
>>> anything > 0.94.18. But, we've decided to move away from EMR and embrace
>>> HDP.
>>>
>>> Thank you all for your help.
>>>
>>> On Thu, Apr 7, 2016 at 3:48 AM, Josh Elser <josh.elser@gmail.com> wrote:
>>>
>>>> (-cc dev@phoenix)
>>>>
>>>> Deepak,
>>>>
>>>> As the name suggests, that release is targeted for HBase-0.98.x release
>>>> lines. Any compatibility of an older release of HBase than 0.98 is likely
>>>> circumstantial.
>>>>
>>>> I can't speak on behalf of the HBase community, but I feel relatively
>>>> confident in suggesting that it would be best to try to upgrade to a recent
>>>> release of HBase-0.98.x if at all possible (the last 0.94 release was over
>>>> a year ago).
>>>>
>>>> Also, please remember that the people helping here are volunteering
>>>> their time. Requesting preferential help is generally frowned upon.
>>>>
>>>> - Josh
>>>>
>>>> Deepak Gopalakrishnan wrote:
>>>>
>>>>> Hello All,
>>>>>
>>>>> Does the package available here
>>>>> :http://a.mbbsindia.com/phoenix/phoenix-4.6.0-HBase-0.98/bin/ support
>>>>> HBase-0.94.18 ?
>>>>>
>>>>> If not, is there a version that is supported for HBase-0.94.18 ?
>>>>>
>>>>> Please help!
>>>>>
>>>>> On Wed, Apr 6, 2016 at 10:42 AM, Deepak Gopalakrishnan <
>>>>> dgkris@gmail.com
>>>>> <mailto:dgkris@gmail.com>> wrote:
>>>>>
>>>>>     Adding Dev group
>>>>>
>>>>>     On Wed, Apr 6, 2016 at 10:35 AM, Deepak Gopalakrishnan
>>>>>     <dgkris@gmail.com <mailto:dgkris@gmail.com>> wrote:
>>>>>
>>>>>         Hello All,
>>>>>
>>>>>         I did move on to 4.7 and my HBase version is 0.98+. Below is
>>>>> the
>>>>>         script I execute in order to get it installed before HBase is
>>>>>         started.
>>>>>
>>>>>
>>>>>
>>>>>         After doing this on all nodes ( including master ), when I try
>>>>> a
>>>>>         ./sqline.py localhost, it just freezes and doesnt proceed. Can
>>>>>         someone please help ?
>>>>>
>>>>>
>>>>>         #!/bin/sh
>>>>>         mkdir /home/hadoop/phoenix/
>>>>>         wget
>>>>>
>>>>> http://mirror.fibergrid.in/apache/phoenix/phoenix-4.7.0-HBase-0.98/bin/phoenix-4.7.0-HBase-0.98-bin.tar.gz
>>>>>         -P /home/hadoop/phoenix/
>>>>>         cd /home/hadoop/phoenix/
>>>>>         tar -xvf phoenix-4.7.0-HBase-0.98-bin.tar.gz
>>>>>         cp -r phoenix-4.7.0-HBase-0.98-bin/phoenix-*.jar
>>>>>         /home/hadoop/hbase/lib/
>>>>>
>>>>>         On Tue, Apr 5, 2016 at 10:39 PM, Deepak Gopalakrishnan
>>>>>         <dgkris@gmail.com <mailto:dgkris@gmail.com>> wrote:
>>>>>
>>>>>             Hello James,
>>>>>
>>>>>             Sure I understand. But any idea why JOIN fails on the
>>>>> server
>>>>>             ? Is it not supported on 2.1.2 ?
>>>>>
>>>>>             Thanks
>>>>>             Deepak
>>>>>
>>>>>             On Tue, Apr 5, 2016 at 9:48 PM, James Taylor
>>>>>             <jamestaylor@apache.org <mailto:jamestaylor@apache.org>>
>>>>> wrote:
>>>>>
>>>>>                 Support for the 2.x line was dropped over a year ago.
>>>>>                 I'd recommend encouraging the EMR folks to upgrade to
>>>>>                 the latest version of Phoenix and HBase.
>>>>>
>>>>>
>>>>>                 On Tuesday, April 5, 2016, Deepak Gopalakrishnan
>>>>>                 <dgkris@gmail.com <mailto:dgkris@gmail.com>>
wrote:
>>>>>
>>>>>                     Hello,
>>>>>
>>>>>                     I'm trying to join two tables that I created using
>>>>>                     Phoenix. My tables are A and B. I've setup phoenix
>>>>>                     on EMR using
>>>>>                     https://phoenix.apache.org/phoenix_on_emr.html.
>>>>> I've
>>>>>                     used the phoenix-2.1.2 version and I can do basic
>>>>>                     queries like SELECT. But when I try a join, I get
>>>>> an
>>>>>                     error. It looks like the SQL query is not even
>>>>> being
>>>>>                     parsed. I'm not sure what I'm doing here. I'm using
>>>>>                     the sqline client on the server itself.
>>>>>
>>>>>                     select A.name,B.dname from A as a inner join B as
b
>>>>>                     on a.name <http://a.name>=b.name <http://b.name>;
>>>>>
>>>>>                     Error: ERROR 602 (42P00): Syntax error. Missing
>>>>>                     "EOF" at line 1, column 35. (state=42P00,code=602)
>>>>>
>>>>>                     Please let me know if you guys can help ?
>>>>>
>>>>>                     --
>>>>>                     Regards,
>>>>>                     *Deepak Gopalakrishnan*
>>>>>                     *Mobile*:+918891509774 <tel:%2B918891509774>
>>>>>                     *Skype* : deepakgk87
>>>>>                     http://myexps.blogspot.com
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>             --
>>>>>             Regards,
>>>>>             *Deepak Gopalakrishnan*
>>>>>             *Mobile*:+918891509774 <tel:%2B918891509774>
>>>>>             *Skype* : deepakgk87
>>>>>             http://myexps.blogspot.com
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>         --
>>>>>         Regards,
>>>>>         *Deepak Gopalakrishnan*
>>>>>         *Mobile*:+918891509774 <tel:%2B918891509774>
>>>>>         *Skype* : deepakgk87
>>>>>         http://myexps.blogspot.com
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>     --
>>>>>     Regards,
>>>>>     *Deepak Gopalakrishnan*
>>>>>     *Mobile*:+918891509774 <tel:%2B918891509774>
>>>>>     *Skype* : deepakgk87
>>>>>     http://myexps.blogspot.com
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> Regards,
>>>>> *Deepak Gopalakrishnan*
>>>>> *Mobile*:+918891509774
>>>>> *Skype* : deepakgk87
>>>>> http://myexps.blogspot.com
>>>>>
>>>>>
>>>
>>>
>>> --
>>> Regards,
>>> *Deepak Gopalakrishnan*
>>> *Mobile*:+918891509774
>>> *Skype* : deepakgk87
>>> http://myexps.blogspot.com
>>>
>>>
>>
>

Mime
View raw message