phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Terrell <sterr...@oculus360.us>
Subject Re: Phoenix transactions not committing.
Date Fri, 01 Apr 2016 14:11:35 GMT
You might try looking up previous emails from me in this mailing list.  I
had some problems doing commits when using the thin client and Phoenix
4.6.0.

Hope this helps,
    Steve

On Thu, Mar 31, 2016 at 11:25 PM, F21 <f21.groups@gmail.com> wrote:

> As I mentioned about a week ago, I am working on a golang client using
> protobuf serialization with the phoenix query server. I have successfully
> dealt with the serialization of requests and responses.
>
> However, I am trying to commit a transaction and just doesn't seem to
> commit.
>
> Here's what I am doing (I am not including the WireMessage message that
> wraps the requests/responses for brevity):
>
> I have a table called "my_table", created by running this sql in Squirrel
> SQL: CREATE TABLE my_table (k BIGINT PRIMARY KEY, v VARCHAR)
> TRANSACTIONAL=true
>
> OpenConnectionRequest {
>   connection_id: "myconnectionid"
> }
>
> statementID = CreateStatementRequest {
>   connection_id: "myconnectionid"
> }
>
> PrepareAndExecuteRequest {
>   connection_id : "myconnectionid"
>   statement_id = statementID
>   sql = " UPSERT INTO my_table VALUES (1,'A')"
> }
>
> CommitRequest {
>   connection_id: "myconnectionid"
> }
>
> After sending the commands to the query service, I executed "SELECT * FROM
> my_table" in Squirrel SQL, but I do not see any records. There also doesn't
> seem to be anything interesting in the tephra or hbase master logs.
>
> What is causing this problem?
>

Mime
View raw message