phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Swapna Swapna <talktoswa...@gmail.com>
Subject Re: Phoenix for CDH5 compatibility
Date Mon, 18 Apr 2016 07:45:42 GMT
Add the phoenix-[version]-server.jar to the classpath of all HBase region
server and master and remove any previous version. An easy way to do this
is to copy it into the HBase lib directory.

On Sun, Apr 17, 2016 at 1:20 AM, Viswanathan J <jayamviswanathan@gmail.com>
wrote:

> What are the required phoenix jars to be copied into HBase libs.
> On Apr 17, 2016 1:17 PM, "Swapna Swapna" <talktoswapna@gmail.com> wrote:
>
>> Thank you Rafa and James. That helps.
>>
>> Regards
>> Swapna
>>
>> On Sat, Apr 16, 2016 at 7:41 AM, James Taylor <jamestaylor@apache.org>
>> wrote:
>>
>>> There's also the branch that Andrew setup here:
>>> https://github.com/chiastic-security/phoenix-for-cloudera
>>>
>>>
>>> On Saturday, April 16, 2016, rafa <rafa13@gmail.com> wrote:
>>>
>>>> Hi Swapna,
>>>>
>>>> You can download the  official parcel from Cloudera, although it is not
>>>> the last phoenix version.
>>>>
>>>> http://archive.cloudera.com/cloudera-labs/phoenix/parcels/latest/
>>>>
>>>> If you want to use higher versions you'll have to compile them against
>>>> the cdh  libraries
>>>>
>>>> Regards,
>>>> Rafa
>>>> El 16/04/2016 12:17, "Swapna Swapna" <talktoswapna@gmail.com> escribió:
>>>>
>>>>> Hi,
>>>>>
>>>>>
>>>>> I was able to use phoenix-4.6.0-HBase-1 in a standalone machine but
>>>>> when i tried to use with cdh5, its throwing the below exception. After
>>>>> doing some research, noticed this seems to be a common problem faced
by
>>>>> many others as well.
>>>>>
>>>>> Caused by: java.lang.NoSuchMethodError:
>>>>> org.apache.hadoop.hbase.client.Scan.setRaw(Z)Lorg/apache/hadoop/hbase/client/Scan;
>>>>>
>>>>> at
>>>>> org.apache.phoenix.coprocessor.MetaDataEndpointImpl.buildDeletedTable(MetaDataEndpointImpl.java:973)
>>>>>
>>>>> at
>>>>> org.apache.phoenix.coprocessor.MetaDataEndpointImpl.loadTable(MetaDataEndpointImpl.java:1049)
>>>>>
>>>>> at
>>>>> org.apache.phoenix.coprocessor.MetaDataEndpointImpl.createTable(MetaDataEndpointImpl.java:1223)
>>>>>
>>>>> at
>>>>> org.apache.hadoop.hbase.ipc.RpcClientImpl.call(RpcClientImpl.java:1199)
>>>>>
>>>>> at
>>>>> org.apache.hadoop.hbase.ipc.AbstractRpcClient.callBlockingMethod(AbstractRpcClient.java:216)
>>>>>
>>>>> at
>>>>> org.apache.hadoop.hbase.ipc.AbstractRpcClient$BlockingRpcChannelImplementation.callBlockingMethod(AbstractRpcClient.java:300)
>>>>>
>>>>> at
>>>>> org.apache.hadoop.hbase.protobuf.generated.ClientProtos$ClientService$BlockingStub.execService(ClientProtos.java:31913)
>>>>>
>>>>> at
>>>>> org.apache.hadoop.hbase.protobuf.ProtobufUtil.execService(ProtobufUtil.java:1605)
>>>>>
>>>>>
>>>>> Please suggest me, from where I can download the Phoenix binary/source
>>>>> (for hbase 1.0) to be compatible with cdh5.
>>>>>
>>>>> Regards
>>>>>
>>>>> Swapna
>>>>>
>>>>>
>>

Mime
View raw message