phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <josh.el...@gmail.com>
Subject Re: Phoenix jars on http://mvnrepository.com
Date Mon, 04 Apr 2016 14:08:22 GMT
Hi Pierre,

1.1.2.2.4 is not a version of Apache HBase. Might you be needing to 
contact a vendor for specific information?

Either way, the phoenix shaded client and server (targeted for HBase 
server) are not attached to the Maven build which means that they are 
not deployed via Maven as a part of an Apache Phoenix release.

You can look at the following assembly descriptors for the dependencies 
for both the Phoenix client and server artifacts. These should help you 
create the runtime dependencies for clients and servers:

https://github.com/apache/phoenix/blob/v4.7.0-HBase-1.1/phoenix-assembly/src/build/client.xml

https://github.com/apache/phoenix/blob/v4.7.0-HBase-1.1/phoenix-assembly/src/build/server.xml

- Josh

Pierre Smits wrote:
> Hi all,
>
> I want to pull in the phoenix jars for both a client application and the hbase server
with Apache IVY. Both need to work with hbase version 1.1.2.2.4. And I found this: http://mvnrepository.com/artifact/org.apache.phoenix
>
> Can you tell me to which artifact I need to point towards?
>
> Best regards,
>
> Pierre
> ------
> Sent via Pony Mail for user@phoenix.apache.org.
> View this email online at:
> https://pony-poc.apache.org/list.html?user@phoenix.apache.org

Mime
View raw message