phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ankit Singhal <ankitsingha...@gmail.com>
Subject Re: Problem Updating Stats
Date Thu, 17 Mar 2016 05:36:49 GMT
ok , or you could have drop SYSTEM.STATS table from sql client at
CURRENT_SCN=7 and reconnect the client. If client doesn't see this table ,
it will create it automatically.

On Thu, Mar 17, 2016 at 3:14 AM, Benjamin Kim <bbuild11@gmail.com> wrote:

> I got it to work by uninstalling Phoenix and reinstalling it again. I had
> to wipe clean all components.
>
> Thanks,
> Ben
>
>
> On Mar 16, 2016, at 10:47 AM, Ankit Singhal <ankitsinghal59@gmail.com>
> wrote:
>
> It seems from the attached logs that you have upgraded phoenix to 4.7
> version and now you are using old client to connect with it.
> "Update statistics" command and guideposts will not work with old client
> after upgradation to 4.7, you need to use the new client for such
> operations.
>
> On Wed, Mar 16, 2016 at 10:55 PM, Benjamin Kim <bbuild11@gmail.com> wrote:
>
>> | TABLE_CAT | TABLE_SCHEM | TABLE_NAME | COLUMN_NAME
>>          |       |
>>
>> +-----------------+----------------------+---------------------+------------------------------------------------+-----+
>> |                      | SYSTEM            | STATS              |
>> PHYSICAL_NAME                            | 12  |
>> |                      | SYSTEM            | STATS              |
>> COLUMN_FAMILY                            | 12  |
>> |                      | SYSTEM            | STATS              |
>> GUIDE_POST_KEY                          | -3   |
>> |                      | SYSTEM            | STATS              |
>> GUIDE_POSTS_WIDTH                   | -5   |
>> |                      | SYSTEM            | STATS              |
>> LAST_STATS_UPDATE_TIME         | 91  |
>> |                      | SYSTEM            | STATS              |
>> GUIDE_POSTS_ROW_COUNT       | -5   |
>>
>> I have attached the SYSTEM.CATALOG contents.
>>
>> Thanks,
>> Ben
>>
>>
>>
>> On Mar 16, 2016, at 9:34 AM, Ankit Singhal <ankitsinghal59@gmail.com>
>> wrote:
>>
>> Sorry Ben, I may not be clear in first comment but I need you to describe
>> SYSTEM.STATS in some sql client so that I can see the columns present.
>> And also please scan 'SYSTEM.CATALOG' ,{RAW=>true} in hbase shell and
>> attach a output here.
>>
>> On Wed, Mar 16, 2016 at 8:55 PM, Benjamin Kim <bbuild11@gmail.com> wrote:
>>
>>> Ankit,
>>>
>>> I did not see any problems when connecting with the phoenix sqlline
>>> client. So, below is the what you asked for. I hope that you can give us
>>> insight into fixing this.
>>>
>>> hbase(main):005:0> describe 'SYSTEM.STATS'
>>> Table SYSTEM.STATS is ENABLED
>>>
>>>
>>> SYSTEM.STATS, {TABLE_ATTRIBUTES => {coprocessor$1 =>
>>> '|org.apache.phoenix.coprocessor.ScanRegionObserver|805306366|',
>>> coprocessor$2 => '|org.apache.phoenix.coprocessor.UngroupedAggr
>>> egateRegionObserver|805306366|', coprocessor$3 =>
>>> '|org.apache.phoenix.coprocessor.GroupedAggregateRegionObserver|805306366|',
>>> coprocessor$4 => '|org.apache.phoenix.coprocessor.Serv
>>> erCachingEndpointImpl|805306366|', coprocessor$5 =>
>>> '|org.apache.hadoop.hbase.coprocessor.MultiRowMutationEndpoint|805306366|',
>>> coprocessor$6 => '|org.apache.hadoop.hbase.regionserv
>>> er.LocalIndexSplitter|805306366|', METADATA => {'SPLIT_POLICY' =>
>>> 'org.apache.phoenix.schema.MetaDataSplitPolicy'}}
>>>
>>> COLUMN FAMILIES DESCRIPTION
>>>
>>>
>>> {NAME => '0', DATA_BLOCK_ENCODING => 'FAST_DIFF', BLOOMFILTER => 'ROW',
>>> REPLICATION_SCOPE => '0', VERSIONS => '3', COMPRESSION => 'NONE',
>>> MIN_VERSIONS => '0', TTL => 'FOREVER', KEEP
>>> _DELETED_CELLS => 'true', BLOCKSIZE => '65536', IN_MEMORY => 'false',
>>> BLOCKCACHE => 'true'}
>>>
>>> 1 row(s) in 0.0280 seconds
>>>
>>> Thanks,
>>> Ben
>>>
>>>
>>> On Mar 15, 2016, at 11:59 PM, Ankit Singhal <ankitsinghal59@gmail.com>
>>> wrote:
>>>
>>> Yes it seems to.
>>> Did you get any error related to SYSTEM.STATS when the client is
>>> connected first time ?
>>>
>>> can you please describe your system.stats table and paste the output
>>> here.
>>>
>>> On Wed, Mar 16, 2016 at 3:24 AM, Benjamin Kim <bbuild11@gmail.com>
>>> wrote:
>>>
>>>> When trying to run update status on an existing table in hbase, I get
>>>> error:
>>>>
>>>> Update stats:
>>>>
>>>> UPDATE STATISTICS "ops_csv" ALL
>>>>
>>>> error:
>>>>
>>>> ERROR 504 (42703): Undefined column. columnName=REGION_NAME
>>>>
>>>> Looks like the meta data information is messed up, ie. there is no
>>>> column with name REGION_NAME in this table.
>>>>
>>>> I see similar errors for other tables that we currently have in hbase.
>>>>
>>>> We are using CDH 5.5.2, HBase 1.0.0, and Phoenix 4.5.2.
>>>>
>>>> Thanks,
>>>> Ben
>>>>
>>>
>>>
>>>
>>
>>
>>
>
>

Mime
View raw message