phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pedro Gandola <pedro.gand...@gmail.com>
Subject Re: Local Indexes are not used to query views
Date Thu, 14 Jan 2016 17:19:05 GMT
Hi James,

Sure, I will do it.

Thanks
Cheers

On Thu, Jan 14, 2016 at 5:01 PM, James Taylor <jamestaylor@apache.org>
wrote:

> Thanks for reporting this, Pedro. I tried it on 4.7-SNAPSHOT and it works
> for non local indexes, but not for local indexes. Please file a JIRA.
>
>    James
>
> On Thu, Jan 14, 2016 at 8:34 AM, Pedro Gandola <pedro.gandola@gmail.com>
> wrote:
>
>> Hi,
>>
>> I've noticed that Phoenix (using version 4.4) when querying a view it
>> does not consider the original table local indexes to optimise the query.
>>
>> If I explain my query over the original table it's using the local index
>> properly:
>>
>> *EXPLAIN SELECT * FROM BIDDING_EVENTS WHERE wTs IS NOT NULL;*
>>> CLIENT 300-CHUNK PARALLEL 300-WAY RANGE SCAN OVER
>>> _LOCAL_IDX_BIDDING_EVENTS [-32768]
>>>      SERVER FILTER BY "WTS" IS NOT NULL
>>
>>
>> However, If I create a view using the exact same query and explain I get
>> a full scan.
>>
>>
>>> *CREATE VIEW WINS_VIEW AS SELECT * FROM BIDDING_EVENTS WHERE wTs IS NOT
>>> NULL; *
>>
>> *EXPLAIN SELECT * FROM WINS_VIEW;*
>>> CLIENT 300-CHUNK PARALLEL 1-WAY FULL SCAN OVER BIDDING_EVENTS
>>>      SERVER FILTER BY WTS IS NOT NULL
>>
>>
>> Is this the expected behaviour? Or could this be an issue with 4.4
>> version?
>>
>> Thank you
>> Cheers
>> Pedro
>>
>
>

Mime
View raw message