phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Veerraju Tadimeti <tvvr...@gmail.com>
Subject Error while gradle build for Phoenix 4.4.0-HBase-1.0 : could not resolve ${compat.module}
Date Wed, 15 Jul 2015 21:19:21 GMT
Hi,

I am trying to build gradle having phoenix 4.4.0-HBase-1.0 dependency for
CDH 5.4.3.  Please let me know the fix.

build.gradle contains the following code:

compile (group: 'org.apache.phoenix', name: 'phoenix-core', version:
'4.4.0-HBase-1.0') {
exclude(module: 'sqlline')
}

Exception :

*Could not resolve org.apache.hbase:${compat.module}:1.0.1.*
     Required by:
         com.mycompany.xxx:xxx-service:0.0.2.0 >
org.apache.hbase:hbase-server:1.0.1
         com.mycompany.xxx:xxx-service:0.0.2.0 >
org.apache.hbase:hbase-server:1.0.1 >
org.apache.hbase:hbase-prefix-tree:1.0.1
      > Illegal character in path at index 74:
http://subdomain.mycompany.com:8081/artifactory/repo/org/apache/hbase/${compat.module}/1.0.1/${compat.module}-1.0.1.pom
      > Illegal character in path at index 77:
http://xxx.xx.xx.xxx:8081/artifactory/libs-snapshot-local/org/apache/hbase/${compat.module}/1.0.1/${compat.module}-1.0.1.pom

Thanks,
Raju,
(972)273-0155.

Mime
View raw message