phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Taylor <jamestay...@apache.org>
Subject Re: peoblem with 4.3 client and java 1.6
Date Mon, 02 Mar 2015 00:43:12 GMT
Hi Noam,
Java 1.6 was end of life more than a year ago, so Phoenix binaries no
longer support it. You can likely compile the Phoenix 4.3 source
against Java 1.6 yourself - I don't think we rely on 1.7 features
much.
Thanks,
James

On Sun, Mar 1, 2015 at 10:43 AM, Bulvik, Noam <Noam.Bulvik@teoco.com> wrote:
> Hi,
>
>
>
> We are using weblogic 10.3.x which comes with java 1.6. we used phoenix 4.1
> without any problem but both 4.2 and 4.3 can’t be used because we are
> getting java.lang.UnsupportedClassVersionError:
> org/apache/phoenix/jdbc/PhoenixDriver : Unsupported major.minor version 51.0
>
>
>
> Can you continue to compile client jars with java 1.6 compatible ?
>
>
>
> Thanks ,
>
>
>
>
>
> Noam Bulvik
>
> R&D Manager
>
>
>
> TEOCO CORPORATION
>
> c: +972 54 5507984
>
> p: +972 3 9269145
>
> Noam.Bulvik@teoco.com
>
> www.teoco.com
>
>
>
> Information in this e-mail and its attachments is confidential and
> privileged under the TEOCO confidentiality terms that can be reviewed here.

Mime
View raw message