phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mujtaba Chohan <mujt...@apache.org>
Subject Re: Incompatible jars detected between client and server with CsvBulkloadTool
Date Thu, 26 Feb 2015 20:18:16 GMT
Just tried connecting Sqlline using Phoenix 4.3 with clean HBase
0.98.4-hadoop2 and it worked fine. Any change you are using hadoop1?

On Thu, Feb 26, 2015 at 10:38 AM, Naga Vijayapuram <Naga_Vijayapuram@gap.com
> wrote:

>  Hi Sun,
>
>  See my comment in https://issues.apache.org/jira/browse/PHOENIX-1248 …
>
>  ||||||||||
> With Phoenix 4.3.0, I had to move from HBase 0.98.4 to HBase 0.98.9 to
> overcome the issue ...
> ||||||||||
>
>  Naga
>
>
>  On Feb 26, 2015, at 1:57 AM, sunfl@certusnet.com.cn wrote:
>
>
> Hi, all
>
>  With the latest 4.3 release, I got strange error of incompatible jars
> for client and server, as following:
>
>    Exception in thread "main" java.sql.SQLException: ERROR 2006 (INT08):
> Incompatible jars detected between client and server. Ensure that
> phoenix.jar is put on the classpath of HBase in every region server:
> org.apache.hadoop.hbase.protobuf.generated.ZooKeeperProtos$MetaRegionServer.hasState()Z
>
>  Never had seen this kind of exception before. I am sure server jar and
> client jar are both phoenix-4.3.0
>
>  Any hints are accepted and appreciated.
>  Thanks,
>  Sun.
> ------------------------------
>   ------------------------------
>  CertusNet
>
>
>

Mime
View raw message