phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jamie Murray <Jamie.Mur...@D2L.com>
Subject RE: Phoenix 4.2.2 compatibility with HBase 0.98.9
Date Tue, 13 Jan 2015 20:54:19 GMT
As a follow up to our issue. 

We needed to add the phoenix server jar to our hbase master nodes.  This was not the case
for HBase 0.98.5.  We saw this issue for both Phoenix 4.2.0 and 4.2.2, it looks like a change
in Hbase has caused this requirement. 

According the Phoenix docs:

"Add the phoenix-[version]-server.jar to the classpath of every HBase region server and remove
any previous version. An easy way to do this is to copy it into the HBase lib directory (use
phoenix-core-[version].jar for Phoenix 3.x)" 

Seems to imply the server jar only needs to be on the region servers, which actually worked
in our old HBase version.   I don't know enough about Phoenix to understand why we saw this
issue, just an interesting observation.  

Jamie

-----Original Message-----
From: Jamie Murray [mailto:Jamie.Murray@D2L.com] 
Sent: January-13-15 1:12 PM
To: user@phoenix.apache.org
Subject: RE: Phoenix 4.2.2 compatibility with HBase 0.98.9

Okay, that’s what I was looking for.  Must be another issue. 

Thanks! 

Jamie

-----Original Message-----
From: James Taylor [mailto:jamestaylor@apache.org]
Sent: January-13-15 1:11 PM
To: user
Subject: Re: Phoenix 4.2.2 compatibility with HBase 0.98.9

FWIW, I just installed Phoenix 4.2.2 with HBase 0.98.9 and everything went smoothly.

Thanks,
James

On Tue, Jan 13, 2015 at 10:04 AM, Jeffrey Zhong <jzhong@hortonworks.com> wrote:
>
> The error normally is due to phoenix-4.2.2-server.jar isn't in your 
> hbase region server & master class path. You can double check if that's the case.
>
> From: Jamie Murray <Jamie.Murray@D2L.com>
> Reply-To: <user@phoenix.apache.org>
> Date: Tuesday, January 13, 2015 at 8:37 AM
> To: "user@phoenix.apache.org" <user@phoenix.apache.org>
> Subject: Phoenix 4.2.2 compatibility with HBase 0.98.9
>
> Hello!
>
>
>
> We have recently updated our Hbase to 0.98.9 and we are now getting 
> this error
>
>
>
> Error: org.apache.hadoop.hbase.DoNotRetryIOException: java.io.IOException:
> Class org.apache.phoenix.coprocessor.MetaDataEndpointImpl cannot be 
> loaded
>
>
>
> When attempting to connect to Phoenix 4.2.2 (sqlline.py).    I am just
> wondering if anyone has gotten these 2 versions to work together 
> nicely and we should be looking elsewhere for the origin of this error.
>
>
>
> Thanks,
>
>
>
> Jamie
>
>
> CONFIDENTIALITY NOTICE
> NOTICE: This message is intended for the use of the individual or 
> entity to which it is addressed and may contain information that is 
> confidential, privileged and exempt from disclosure under applicable 
> law. If the reader of this message is not the intended recipient, you 
> are hereby notified that any printing, copying, dissemination, 
> distribution, disclosure or forwarding of this communication is 
> strictly prohibited. If you have received this communication in error, 
> please contact the sender immediately and delete it from your system. Thank You.
Mime
View raw message