phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vladimir Rodionov <vladrodio...@gmail.com>
Subject Re: Regionserver Crashing whenever join query run_tables with 10lac rows
Date Wed, 12 Nov 2014 17:53:07 GMT
What does RS log file say, Siddharth?

Btw, what does 'lac' stand for? In '10 lac'?

-Vladimir

On Wed, Nov 12, 2014 at 6:32 AM, Puneet Kumar Ojha <
puneet.kumar@pubmatic.com> wrote:

>  Hi Siddharth,
>
>
>
> Please go for following optimizations: -
>
>
>
> Increase the xceivers property to 16k in hbase site xml.
>
> Increase the region server handler count to 60.
>
> Decrease salt buckets for the tables.At least for the smaller table.
>
>
>
> It shud help.
>
>
>
> Thanks
>
>
>
>
>
> ------ Original message------
>
> *From: *Siddharth Ubale
>
> *Date: *Wed, Nov 12, 2014 19:29
>
> *To: *user@phoenix.apache.org;
>
> *Subject:*Regionserver Crashing whenever join query run_tables with 10lac
> rows
>
>
>
> Hi ,
>
>
>
> We are using 4 node hbase cluster with phoenix with the following config:
>
> Phoenix 4.2
>
> Hbase 0.98.7
>
> Hadoop 2.5
>
>
>
> We have two tables each containing 10 lac records. Whenever we run a query
> from any of the 4 clients ,which performs a join on these tables the region
> server crashes and we are unable to get any result. Our nodes are
> essentially 150Gb machines with 8 cores and 8 gb Ram except one which has
> 16 cores and 16gb ram. We are still analyzing Phoenix for our project. And
> we seem to have hit a roadblock.
>
> Can anyone please let us know what is the problem here ?
>
>
>
> Also, whenever we run join queries on tables having 1 lac records we can
> get results in 2-3 seconds.
>
>
>
> Siddharth Ubale,
>
>
>

Mime
View raw message