phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Taylor <jamestay...@apache.org>
Subject Re: Error in readFields
Date Mon, 29 Sep 2014 22:34:49 GMT
Hi Kristoffer,
Did something change on your cluster prior to the breaking of your
SELECT queries? An upgrade of something?

>From the look of the exceptions, it seems like the Phoenix client jar
and server jar are out-of-sync, because the client is sending
information in a format that's no longer understood by the server.

I do encourage you to upgrade, though, once you get your production
servers functioning again.

Thanks,
James

On Mon, Sep 29, 2014 at 3:17 PM, Kristoffer Sjögren <stoffe@gmail.com> wrote:
> Hi
>
> Our SELECT queries went broken just now and we're seeing the following
> exception [1] using Apache Phoenix 2.2.3-incubating with HBase 0.94.6
> (0.94.6-cdh4.4.0).
>
> After a some testing I realized that sqlline.sh from the 2.2.3-incubating
> tarball is also broken all of a sudden (with same error)?
>
> Seems like SELECT ... WHERE queries are problematic whereas basic queries
> like "SELECT * FROM COUNTERS LIMIT 1;" works fine. Simple INSERT statements
> also seems to be working.
>
> Is upgrading to phoenix-3.0.0-incubating an option? Or is there a way to
> debug this further? I tried to enable DEBUG in log4j.properties using the
> 'console' in sqlline but without success.
>
> Our production servers are pretty much down at the moment...
>
> Cheers,
> -Kristoffer
>
> [1] http://pastebin.com/H2a6xpBX
>

Mime
View raw message