phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gabriel Reid <gabriel.r...@gmail.com>
Subject Re: Error connecting through SQuirrel
Date Thu, 04 Sep 2014 15:20:43 GMT
Hi Abe,

Could you confirm if the issue you were running into with the "List
Drivers" functionality in Squirrel was the same as this:

http://mail-archives.apache.org/mod_mbox/phoenix-user/201408.mbox/%3CCAA5C_psroro3u7o8ns=K8FGeS0JGrn-KvFX4OFkyWCtvwsy6pw@mail.gmail.com%3E

If so, could you say what your client platform is? If you were having
the same issue, we should probably update the documentation on using
Squirrel to include information if you're running on a platform where
this is an issue.

- Gabriel


On Thu, Sep 4, 2014 at 5:08 PM, Abe Weinograd <abe@flonet.com> wrote:
> Hi Anil,
>
> Here is what i did.
>
> 1.  Installed DBVis Free 9.1.10
> 2.  Opened it and went to Tools->Driver Manager
> 3.  Added new driver.
>     a.  Gave it a name, set the URL format of jdbc:phoenix:localhost
>     b.  In the Driver File Paths, click the Open file Icon and selected the
> appropriate client jar
>          For me, that was hadoop2/phoenix-4.1.0-client-hadoop2.jar
>     c.  DBVis scanned the jar and automatically found the Class of the
> driver.
> 4.  Creating a connection
>     a.  I created a connection using the Wizard
>     b.  Select the new driver created above
>     c.  The DB URL is the standard Phoenix JDBC URL in the for
> jdbc:phoenix:<zookeeper quorom>
>
> That's it.  It was easy/simple.  The only oddity i found with Squirrel was
> that i had to hand type the class instead of clicking List Drivers which
> required me to kill Squirrel.
>
> Abe
>
>
>
> On Tue, Sep 2, 2014 at 4:08 PM, anil gupta <anilgupta84@gmail.com> wrote:
>>
>> Hi Abe,
>>
>> Nice that you go it working. It would be great if you can provide steps to
>> use Phoenix with DB Visualizer.
>>
>> Thanks,
>> Anil Gupta
>>
>>
>> On Tue, Sep 2, 2014 at 10:33 AM, Abe Weinograd <abe@flonet.com> wrote:
>>>
>>> Update:  List Drivers in Squirrel 3.5.3 still doen't work.  If i just
>>> type in the class name myself, hit OK and try to connect, it works fine.  DB
>>> Visualizer works too.
>>>
>>> Abe
>>>
>>>
>>> On Tue, Sep 2, 2014 at 12:41 PM, Abe Weinograd <abe@flonet.com> wrote:
>>>>
>>>> Also, I triple checked the classpath from the process it self and it
>>>> looks good.  Doesn't seem to matter where the client jar is when i reference
>>>> it while creating the Driver in Squirrel.
>>>>
>>>> Abe
>>>>
>>>>
>>>> On Tue, Sep 2, 2014 at 12:31 PM, Abe Weinograd <abe@flonet.com> wrote:
>>>>>
>>>>> Yeah.  I wiped and re-installed Squirrel 3.5.3.
>>>>>
>>>>>
>>>>> On Tue, Sep 2, 2014 at 12:22 PM, James Taylor <jamestaylor@apache.org>
>>>>> wrote:
>>>>>>
>>>>>> Double check that you don't have the old Phoenix jar in the Squirrel
>>>>>> classpath still.
>>>>>>
>>>>>> On Tue, Sep 2, 2014 at 9:17 AM, Abe Weinograd <abe@flonet.com>
wrote:
>>>>>> > I just tried this with the new bits and am seeing the same behavior.
>>>>>> > I am
>>>>>> > using the hadoop2/phoenix-4.10-client-hadoop2.jar
>>>>>> >
>>>>>> > Using that directly in Squirrel just breaks.  Putting it in
the lib
>>>>>> > doesn't
>>>>>> > help either.
>>>>>> >
>>>>>> > What am i missing?
>>>>>> >
>>>>>> >
>>>>>> >
>>>>>> > On Wed, Aug 27, 2014 at 3:27 PM, Mujtaba Chohan <mujtaba@apache.org>
>>>>>> > wrote:
>>>>>> >>
>>>>>> >> Just tested latest Phoenix 4.1 RC
>>>>>> >>
>>>>>> >> https://dist.apache.org/repos/dist/dev/phoenix/phoenix-4.1.0-rc1/bin/
with
>>>>>> >> CDH 5.1 and it works fine. Copy hadoop2/phoenix-4.1.0-server-
>>>>>> >> hadoop2.jar on all region servers+restart and use
>>>>>> >> hadoop2/phoenix-4.1.0-client-hadoop2.jar with your client
or use
>>>>>> >> sqline:
>>>>>> >> hadoop2/bin/sqlline.py <zk>
>>>>>> >>
>>>>>> >> //mujtaba
>>>>>> >>
>>>>>> >>
>>>>>> >> On Wed, Aug 20, 2014 at 6:52 AM, Abe Weinograd <abe@flonet.com>
>>>>>> >> wrote:
>>>>>> >>>
>>>>>> >>> Were you able to get this to work?  I just upgraded
HBase to
>>>>>> >>> 0.98.1
>>>>>> >>> (CDH5.1) and also to Phoenix 4.0 from 3.0 using the
incubating
>>>>>> >>> release.
>>>>>> >>> Sqlline seems to work fine.
>>>>>> >>>
>>>>>> >>> I tried using the client jar in the downloadable binaries
which as
>>>>>> >>> you
>>>>>> >>> said, doesn't work.  Rebuilding from scratch didn't
help either.
>>>>>> >>> I
>>>>>> >>> included my hbase-site.xml which also didn't help. 
Looking at the
>>>>>> >>> Squirrel
>>>>>> >>> log4j logs, when i included the larger 4.0 incubating
client, i am
>>>>>> >>> getting
>>>>>> >>> a lot of ClassDefNotFound errors around junit and mockito.
>>>>>> >>>
>>>>>> >>> I did try using the client-without-hbase and then individually
>>>>>> >>> deploy the
>>>>>> >>> hbase and other necessary jars to the Squirrel lib and
that was
>>>>>> >>> able to
>>>>>> >>> connect.  I need to package this easily, so doing it
that way will
>>>>>> >>> be
>>>>>> >>> difficult.
>>>>>> >>>
>>>>>> >>> Oddly it seems that the hadoop1 jar works by itself,
but that
>>>>>> >>> doesn't
>>>>>> >>> make
>>>>>> >>> sense as we are using hadoop 2.3.
>>>>>> >>>
>>>>>> >>> Is there anything i am missing here?
>>>>>> >>>
>>>>>> >>> Thanks,
>>>>>> >>> Abe
>>>>>> >>>
>>>>>> >>>
>>>>>> >>> On Fri, Jul 25, 2014 at 8:55 AM, Gabriel Reid
>>>>>> >>> <gabriel.reid@gmail.com>
>>>>>> >>> wrote:
>>>>>> >>>>
>>>>>> >>>> Hi Sid,
>>>>>> >>>>
>>>>>> >>>> The location of the jar file looks correct. However,
there seems
>>>>>> >>>> to be
>>>>>> >>>> an issue with the build of hadoop2 phoenix-client
jar -- the
>>>>>> >>>> hbase-default.xml in that jar refers to hadoop1
for some reason.
>>>>>> >>>> I'm
>>>>>> >>>> not sure how that would have happened, but I'll
follow it up on
>>>>>> >>>> the
>>>>>> >>>> dev list.
>>>>>> >>>>
>>>>>> >>>> For now, I can think of two options (either of the
following
>>>>>> >>>> should
>>>>>> >>>> work):
>>>>>> >>>> * Add an hbase-site.xml file in the lib directory
of SQuirreL
>>>>>> >>>> that
>>>>>> >>>> sets the hbase.defaults.for.version.skip [1] setting
to true
>>>>>> >>>> * Rebuild the 4.0 release (git tag v4.0.0-incubating-release)
>>>>>> >>>> from
>>>>>> >>>> https://git-wip-us.apache.org/repos/asf/phoenix.git
using the
>>>>>> >>>> -Dhadoop.profile=2 flag (i.e. git checkout
>>>>>> >>>> v4.0.0-incubating-release;
>>>>>> >>>> mvn clean package -Dhadoop.profile=2 -DskipTests)
>>>>>> >>>>
>>>>>> >>>> There is a chance that the first option won't work
if there
>>>>>> >>>> really is
>>>>>> >>>> something fundamentally wrong with the build of
the hadoop2
>>>>>> >>>> version,
>>>>>> >>>> but the second option should work no matter what.
Can you let me
>>>>>> >>>> know
>>>>>> >>>> if either of these does or doesn't work for you?
>>>>>> >>>>
>>>>>> >>>>
>>>>>> >>>> 1.
>>>>>> >>>>
>>>>>> >>>> http://hbase.apache.org/book/config.files.html#hbase.defaults.for.version.skip
>>>>>> >>>>
>>>>>> >>>>
>>>>>> >>>> On Thu, Jul 24, 2014 at 10:11 PM, Siddharth Wagle
>>>>>> >>>> <swagle@hortonworks.com> wrote:
>>>>>> >>>> > Hi,
>>>>>> >>>> >
>>>>>> >>>> > I am connecting from my Mac to remote HBase
running with the
>>>>>> >>>> > core
>>>>>> >>>> > phoenix
>>>>>> >>>> > jar. I have put the client jar file at,
>>>>>> >>>> >
>>>>>> >>>> >
>>>>>> >>>> > /Applications/SQuirreLSQL.app/Contents/Resources/Java/lib/phoenix-4.0.0-incubating-client.jar
>>>>>> >>>> >
>>>>>> >>>> > ]# rpm -qa | grep hbase
>>>>>> >>>> > hbase-0.98.0.2.1.3.0-563.el6.noarch
>>>>>> >>>> >
>>>>>> >>>> > Exception:
>>>>>> >>>> >
>>>>>> >>>> > java.util.concurrent.ExecutionException:
>>>>>> >>>> > java.lang.RuntimeException:
>>>>>> >>>> > java.lang.RuntimeException: hbase-default.xml
file seems to be
>>>>>> >>>> > for and
>>>>>> >>>> > old
>>>>>> >>>> > version of HBase (0.98.1-hadoop1), this version
is
>>>>>> >>>> > 0.98.1-hadoop2
>>>>>> >>>> >     at
>>>>>> >>>> >
>>>>>> >>>> > java.util.concurrent.FutureTask$Sync.innerGet(FutureTask.java:262)
>>>>>> >>>> >
>>>>>> >>>> > I read on another thread that the location
of the client jar is
>>>>>> >>>> > wrong
>>>>>> >>>> > and
>>>>>> >>>> > that it should be in the internal squirrel
lib, without any
>>>>>> >>>> > hint of
>>>>>> >>>> > where
>>>>>> >>>> > that is. Is there a property to provide a hbase-site
to the
>>>>>> >>>> > client?
>>>>>> >>>> >
>>>>>> >>>> > Best Regards,
>>>>>> >>>> > Sid
>>>>>> >>>> >
>>>>>> >>>> >
>>>>>> >>>> >
>>>>>> >>>> > CONFIDENTIALITY NOTICE
>>>>>> >>>> > NOTICE: This message is intended for the use
of the individual
>>>>>> >>>> > or
>>>>>> >>>> > entity to
>>>>>> >>>> > which it is addressed and may contain information
that is
>>>>>> >>>> > confidential,
>>>>>> >>>> > privileged and exempt from disclosure under
applicable law. If
>>>>>> >>>> > the
>>>>>> >>>> > reader of
>>>>>> >>>> > this message is not the intended recipient,
you are hereby
>>>>>> >>>> > notified
>>>>>> >>>> > that any
>>>>>> >>>> > printing, copying, dissemination, distribution,
disclosure or
>>>>>> >>>> > forwarding of
>>>>>> >>>> > this communication is strictly prohibited.
If you have received
>>>>>> >>>> > this
>>>>>> >>>> > communication in error, please contact the
sender immediately
>>>>>> >>>> > and
>>>>>> >>>> > delete it
>>>>>> >>>> > from your system. Thank You.
>>>>>> >>>
>>>>>> >>>
>>>>>> >>
>>>>>> >
>>>>>
>>>>>
>>>>
>>>
>>
>>
>>
>> --
>> Thanks & Regards,
>> Anil Gupta
>
>

Mime
View raw message