phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From chenwenhui <c77...@163.com>
Subject phoenix4.1.0 does not work against HBase0.98.1
Date Tue, 23 Sep 2014 05:38:12 GMT
HBase version is 0.98.1-cdh5.1.0.  
I copied phoenix-core-4.1.0.jar and phoenix-4.1.0-server-hadoop2.jar into /opt/cloudera/parcels/CDH-5.1.0-1.cdh5.1.0.p0.53/lib/hbase/lib/
folder, and restarted HBase. I can see the following output in RegionServer log.
/opt/cloudera/parcels/CDH-5.1.0-1.cdh5.1.0.p0.53/lib/hbase/bin/../lib/phoenix-4.1.0-server-hadoop2.jar:/opt/cloudera/parcels/CDH-5.1.0-1.cdh5.1.0.p0.53/lib/hbase/bin/../lib/phoenix-core-4.1.0.jar


It seems like HBase has found the phoenix, and the SYSTEM.CATALOG table also is displayed
on the HBase UI. But there are many similar errors as follows in RegionServer log.
ERROR org.apache.hadoop.hbase.regionserver.RegionCoprocessorHost: Failed to load coprocessor
org.apache.phoenix.coprocessor.GroupedAggregateRegionObserver
java.io.IOException: No jar path specified for org.apache.phoenix.coprocessor.GroupedAggregateRegionObserver
 ERROR org.apache.hadoop.hbase.regionserver.RegionCoprocessorHost: Failed to load coprocessor
org.apache.phoenix.coprocessor.MetaDataRegionObserver
java.io.IOException: No jar path specified for org.apache.phoenix.coprocessor.MetaDataRegionObserver
I don't know why these classes don't be found?


When executing sqlline.py, got the following error,
Error: ERROR 2006 (INT08): Incompatible jars detected between client and server. Ensure that
phoenix.jar is put on the classpath of HBase in every region server: org.apache.hadoop.hbase.exceptions.UnknownProtocolException:
No registered coprocessor service found for name MetaDataService in region SYSTEM.CATALOG,,1411367741031.d5be3a939a02d334dd3472016edbccc0.
It seems like these errors were caused by the same reason.
Mime
View raw message