Really sorry, shared the wrong config


<property>
  <name>hbase.regionserver.wal.codec</name>
  <value>org.apache.hadoop.hbase.regionserver.wal.IndexedWALEditCodec</value>
</property>


Regards,
Abhilash L L
Capillary Technologies
M:919886208262
abhilash@capillarytech.com | www.capillarytech.com

Email from people at capillarytech.com may not represent official policy of  Capillary Technologies unless explicitly stated. Please see our Corporate-Email-Policy for details. Contents of this email are confidential. Please contact the Sender if you have received this email in error.



On Fri, Aug 8, 2014 at 1:07 PM, Saravanan A <asaravanan@alphaworkz.com> wrote:
Hi Abhilash, 

Thanks for the replay...i included above property and restarted the region servers but still am getting the same error...



On Fri, Aug 8, 2014 at 12:39 PM, Abhilash L L <abhilash@capillarytech.com> wrote:
Hi Saravanan,

    Please check the Setup section here


   You will need to add this config to all Region Servers in hbase-site. xml, as the error says as well (You will need to restart the servers after the change)



<property>
  <name>hbase.region.server.rpc.scheduler.factory.class</name>
  <value>org.apache.phoenix.hbase.index.ipc.PhoenixIndexRpcSchedulerFactory</value>
  <description>Factory to create the Phoenix RPC Scheduler that knows to put index updates into index queues</description>
</property>



Regards,
Abhilash L L
Capillary Technologies
M:919886208262

Email from people at capillarytech.com may not represent official policy of  Capillary Technologies unless explicitly stated. Please see our Corporate-Email-Policy for details. Contents of this email are confidential. Please contact the Sender if you have received this email in error.



On Fri, Aug 8, 2014 at 12:22 PM, Saravanan A <asaravanan@alphaworkz.com> wrote:

Hi,

    I have a table in hbase and created view in phoenix and try to create index on a column on the view..but i got following error..

Error: ERROR 1029 (42Y88): Mutable secondary indexes must have the hbase.regionserver.wal.codec property set to org.apache.hadoop.hbase.regionserver.wal.IndexedWALEditCodec in the hbase-sites.xml of every region server tableName=tab2_col4 (state=42Y88,code=1029)


but i have added the hbase.regionserver.wal.codec property in all my region server...i can able to create IMMUTABLE index for that...

Am using Hbase ---0.94.15-cdh4.7.0
            Phoenix---3.0


am i missing something???
thanks in advance...


Regards,
Saravanan



Email from people at capillarytech.com may not represent official policy of Capillary Technologies unless explicitly stated. Please see our Corporate-Email-Policy for details.Contents of this email are confidential. Please contact the Sender if you have received this email in error.



Email from people at capillarytech.com may not represent official policy of Capillary Technologies unless explicitly stated. Please see our Corporate-Email-Policy for details.Contents of this email are confidential. Please contact the Sender if you have received this email in error.