phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gabriel Reid <gabriel.r...@gmail.com>
Subject Re: CsvBulkLoadTool error with Phoenix 4.0
Date Thu, 07 Aug 2014 19:10:45 GMT
Hi Vadim,

Sorry for the long delay on this.

Just to be sure, can you confirm that you're using the hadoop-2 build
of Phoenix 4.0 on the client when starting up the CsvBulkLoadTool?

Even if you are, this may actually require a rebuild of Phoenix using
CDH 5.1.0 dependencies.

Could you post the full stack trace that you're getting?

- Gabriel

On Mon, Aug 4, 2014 at 11:08 AM, Azarov, Vadim <Vadim.Azarov@teoco.com> wrote:
> Hi,
>
> I'm getting this error when trying to use the sample bulk loading with
> MapReduce via CsvBulkLoadTool -
>
> java.lang.NoSuchMethodError: org.apache.hadoop.net.NetUtils.getInputStream
>
>
>
> I'm using Phoenix 4.0, HBase 0.98.1 , Hadoop 2.3.0 and Clouder CDH 5.1.0
>
>
>
> I saw that other encountered this problem with older and possibly
> mismatching versions –
>
> http://stackoverflow.com/questions/15363490/cascading-hbase-tap
>
>
>
> but thought that the latest ones should work ok.
>
>
>
> Could you suggest what seems to be the problem?
>
>
>
> Thank you,
>
> Vadim Azarov
>
>
>
> Information in this e-mail and its attachments is confidential and
> privileged under the TEOCO confidentiality terms that can be reviewed here.

Mime
View raw message