phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cosmin Cătălin Sanda <cosmincata...@gmail.com>
Subject Phoenix 4.0.0 and DbVizualizer Pro 9.1.9
Date Fri, 18 Jul 2014 09:47:46 GMT
Hi

I am trying to use Phoenix with DbVizualizer, and I seem to stumble on
a problem that has appeared before, but which I cannot fix. I have two
test scenarios:

Without an HBase cluster I follow these steps:

 - Configure the JDBC driver in DBVizualizer by using
phoenix-4.0.0-incubating-client.jar and everything seems correct.
 - Connect to a nonexisting HBase cluster just for the heck of it.
 - I get the infamous:

   hbase-default.xml file seems to be for and old version of HBase
(null), this version is 0.98.1-hadoop2

With an HBase cluster up and running:

  - Use ./sqlline.py to connect to the cluster, Connection is made
successful and I am able to work with HBase to the full.
  - Use DbVizualizer to connect to the same cluster:
  - I get the infamous:

   hbase-default.xml file seems to be for and old version of HBase
(null), this version is 0.98.1-hadoop2

I have added

<property>
   <name>hbase.defaults.for.version.skip</name>
   <value>true</value>
</property>

to all the hbase-site.xml files on all nodes of the cluster that had
HBase installed, both to the actual HBase conf/hbase-site.xml
configuration and to the Phoenix configuration in bin/hbase-site.xml

Is there anything else I'm missing?

------------------------------------
Cosmin Catalin SANDA
Software Systems Engineer
Phone: +45.27.30.60.35

Mime
View raw message