phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ashish tapdiya <ashishtapd...@gmail.com>
Subject Re: Error: ERROR 203 (22005): Type mismatch.
Date Tue, 15 Jul 2014 17:54:13 GMT
Thanks for the info James.




On Tue, Jul 15, 2014 at 12:39 PM, James Taylor <jamestaylor@apache.org>
wrote:

> We'll get an RC out hopefully next week and if all goes well, we'll
> release by the end of the month.
> Thanks,
> James
>
> On Tue, Jul 15, 2014 at 7:32 PM, ashish tapdiya <ashishtapdiya@gmail.com>
> wrote:
> > Hi James,
> >
> > Jira no. is PHOENIX-1049. Below is a link to page
> >
> http://mail-archives.apache.org/mod_mbox/phoenix-dev/201406.mbox/%3CJIRA.12723505.1403649977329.41328.1403649985092@arcas%3E
> >
> > When is 3.1 gonna come out.
> >
> > Thanks and appreciate the help.
> > ~Ashish
> >
> >
> > On Tue, Jul 15, 2014 at 12:24 PM, James Taylor <jamestaylor@apache.org>
> > wrote:
> >>
> >> Hi,
> >> All bug fixes are applied to both the 3.0 and 4.0 branch, So the fix
> >> should appear in our upcoming 3.1/4.1 release. If you can track down
> >> the JIRA, I can double check for you.
> >>
> >> Thanks,
> >> James
> >>
> >> On Tue, Jul 15, 2014 at 7:20 PM, ashish tapdiya <
> ashishtapdiya@gmail.com>
> >> wrote:
> >> > Hi,
> >> >
> >> > I am using Phoenix secondary index and join functionality.
> >> >
> >> > I have two tables customer and orders.
> >> > I also have an index on customer non key attribute c_uname
> >> >
> >> > One join ordering works while other gives a type mismatch error
> >> > especially
> >> > with the secondary index:
> >> >
> >> > The one that works:
> >> > explain select * from customer as c inner join orders as o on c.c_id =
> >> > o.o_c_id where c.c_uname ='RI';
> >> >
> >> > The one that doesn't work:
> >> > explain select * from orders as o inner join customer as c on c.c_id =
> >> > o.o_c_id where c.c_uname ='RI';
> >> >
> >> > Error msg:Error: ERROR 203 (22005): Type mismatch. expected: VARCHAR
> but
> >> > was: INTEGER at column: C.0:C_UNAME (state=22005,code=203)
> >> >
> >> > Phoenix version: 3.0
> >> > HBase version: .94
> >> >
> >> > I do see in the list that some one else had reported this error before
> >> > and
> >> > its fixed in 4.0 release. I do not want to upgrade since i will have
> to
> >> > change entire stack from hadoop upwards. Is there a way to fix it in
> 3.0
> >> > release?
> >> >
> >> > Thanks,
> >> > ~Ashish
> >
> >
>

Mime
View raw message