phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Taylor <jamestay...@apache.org>
Subject Re: Use SQuirell to connect to Phoenix to a Secure HBase cluster
Date Sat, 03 May 2014 01:19:46 GMT
Awesome, Anil! Congrats. Is your patch on PHOENIX-19 current and ready for
review?  There have been a few fixes in the area of properties, so suspect
you won't need the work around you have in there for
QueryConnectionServicesImpl.

Thanks, and great job!

James


On Thu, May 1, 2014 at 3:17 PM, anil gupta <anilgupta84@gmail.com> wrote:

> Woohoo..Got it working on a secure cluster. I had a mistake in connection
> string.
> I was missing ":phoenix" in my connection string.
> Now, it works with this connection string:
> jdbc:*phoenix*:<ZK>:<port>:<rootdir>:<keytab>:<principal>
>
>
>
>
>
>
>
> On Wed, Apr 30, 2014 at 11:54 AM, anil gupta <anilgupta84@gmail.com>wrote:
>
>> Hi All,
>>
>> I was successful in connecting Phoenix to secure as part of my effort
>> with Phoenix-19 jira. This was done using command line.
>> Now, i want to use SQuirell to connect to a Secure HBase using Phoenix.
>> Here is what i did:
>>
>> 1. I recompiled Phoenix with HBase0.94.19(HBase version with security
>> stuff as default build)
>> 2. I added the Phoenix JDBC client driver in SQuirel.
>> 3. I put conf files for my secure cluster under lib directory so that
>> they are in classpath.
>> 4. In the connection URL i am passing:
>> jdbc:<ZK>:<port>:<rootdir>:<keytab>:<principal>
>> Note: I dont pass any parameters in UserName and Password for connection.
>> Is that right?
>>
>> Can anyone tell me what extra steps i need to take? I am pretty new to
>> Squirell.
>>
>> Squirel is running on Mac. I am using cdh4.6.
>>
>> --
>> Thanks & Regards,
>> Anil Gupta
>>
>
>
>
> --
> Thanks & Regards,
> Anil Gupta
>

Mime
View raw message