Thanks for the advice so far!

Stan: I changed it to debug, and I got the output as attached. And yes, I'm using CDH 4.6 that is using the Cloudera HBase 0.94.15.

Mujtaba: I tried dropping the SYSTEM.CATALOG table, but that doesn't seem to have worked sadly :(


On Thu, Apr 3, 2014 at 1:51 PM, Mujtaba Chohan <mujtaba@apache.org> wrote:
- There should be no difference 2.2.3 jars on download page and 2.2.4 from git.
- You can trouble shoot ZK related issues by running hbase zkcli command https://hbase.apache.org/book/trouble.tools.html.
- With phoenix-3.0.0-RC3, also try dropping SYSTEM.CATALOG table from HBase shell before attempting to reconnect.


On Thu, Apr 3, 2014 at 1:38 PM, Young Kim <ykim@crunchyroll.com> wrote:
Stan: How would I go about changing the log4j properties?

As a side note, I also tried switching to the 2.0 branch to see if phoenix-2.2.4 would resolve the issue, but the results were the same. However, using the jar on the main downloads page (phoenix-2.2.3) works perfectly fine. Anyone know if there is a real difference between the main build and the git ones?



On Thu, Apr 3, 2014 at 1:33 PM, Stan Campbell <stan.campbell3@gmail.com> wrote:
I've had this kind of issue when a port is closed and it eventually times out.  You might be able to tease out the specifics if you bump your logj4 up to DEBUG logging?


On Thu, Apr 3, 2014 at 12:52 PM, Young Kim <ykim@crunchyroll.com> wrote:
There's no log output from HBase. Zookeeper's output is that the connection was successfully established. Any other suggestions? :(


On Thu, Apr 3, 2014 at 6:22 AM, Abe Weinograd <abe@flonet.com> wrote:
I have had that problem when something isn't set up properly on the HBase side.  What do your zookeeper and HBase logs look like?


On Wed, Apr 2, 2014 at 10:49 PM, Young Kim <ykim@crunchyroll.com> wrote:
Hello,

I'm currently having trouble running sqlline.py. In particular, when I run it, the following output is displayed, then the program hangs:

[cloudera@localhost bin]$ ./sqlline.py localhost
Setting property: [isolation, TRANSACTION_READ_COMMITTED]
issuing: !connect jdbc:phoenix:localhost none none org.apache.phoenix.jdbc.PhoenixDriver
Connecting to jdbc:phoenix:localhost
14/04/02 19:27:00 WARN conf.Configuration: dfs.df.interval is deprecated. Instead, use fs.df.interval
14/04/02 19:27:00 WARN conf.Configuration: hadoop.native.lib is deprecated. Instead, use io.native.lib.available
14/04/02 19:27:00 WARN conf.Configuration: fs.default.name is deprecated. Instead, use fs.defaultFS
14/04/02 19:27:00 WARN conf.Configuration: topology.script.number.args is deprecated. Instead, use net.topology.script.number.args
14/04/02 19:27:00 WARN conf.Configuration: dfs.umaskmode is deprecated. Instead, use fs.permissions.umask-mode
14/04/02 19:27:00 WARN conf.Configuration: topology.node.switch.mapping.impl is deprecated. Instead, use net.topology.node.switch.mapping.impl
14/04/02 19:27:01 WARN conf.Configuration: fs.default.name is deprecated. Instead, use fs.defaultFS
14/04/02 19:27:02 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable

I'm currently running this on a standalone Cloudera VM, which is using CDH4.6.0. The version of Phoenix I'm running is v3.0.0-incubating-rc3. Can someone shed some light into this?

Thanks,
Young Kim