phoenix-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karavany, Ido" <ido.karav...@intel.com>
Subject Phoenix and CDH 5 (HBase 0.96)
Date Thu, 10 Apr 2014 04:48:35 GMT
Hi All,

We are trying to install any phoenix version (2.3.3 / 3.0.0 / 4.0.0) on CDH 5 (HBase 0.96)
with no success.

What was done?


1.       Download binary tar

2.       Untar

3.       Copy core jar file to /usr/lib/hbase/lib

4.       Restart all hbase services

5.       Execute sqlline.py

We are at the end of upgrading to CDH 5 and this is currently our only roadblock
Can you please advise on what should be done or how can we make it work?

Thanks,
Ido

Error messages:

For 4.0.0:

Error: ERROR 2006 (INT08): Incompatible jars detected between client and server. Ensure that
phoenix.jar is put on the classpath of HBase in every region server: org.apache.hadoop.hbase.exceptions.UnknownProtocolException:
No registered coprocessor service found for name MetaDataService in region SYSTEM.CATALOG,,1397104167250.b4fd3c9b08093b8b6a68f49884330890.
(state=INT08,code=2006)

For 2.3.3 / 3.0.0:

phoenix Not a host:port pair: PBUF



---------------------------------------------------------------------
Intel Electronics Ltd.

This e-mail and any attachments may contain confidential material for
the sole use of the intended recipient(s). Any review or distribution
by others is strictly prohibited. If you are not the intended
recipient, please contact the sender and delete all copies.

Mime
View raw message